Bug 632551 - [abrt] system-config-printer-1.2.4-1.fc14: jobviewer.py:2080:_set_job_document_text:KeyError: 20
Summary: [abrt] system-config-printer-1.2.4-1.fc14: jobviewer.py:2080:_set_job_documen...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:910d8fe3
: 693055 708989 710354 714330 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-10 10:49 UTC by Steven Haigh
Modified: 2011-11-04 20:29 UTC (History)
6 users (show)

Fixed In Version: system-config-printer-1.2.9-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-21 17:12:52 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (602 bytes, text/plain)
2010-09-10 10:49 UTC, Steven Haigh
no flags Details
suggested patch (3.54 KB, patch)
2010-09-13 14:48 UTC, Jiri Popelka
no flags Details | Diff

Description Steven Haigh 2010-09-10 10:49:53 UTC
abrt version: 1.1.13
architecture: i686
cmdline: /usr/bin/python /usr/share/system-config-printer/applet.py
component: system-config-printer
executable: /usr/share/system-config-printer/applet.py
kernel: 2.6.35.4-12.fc14.i686.PAE
package: system-config-printer-1.2.4-1.fc14
reason: jobviewer.py:2080:_set_job_document_text:KeyError: 20
release: Fedora release 14 (Laughlin)
How to reproduce: Editing a printer via http://localhost:631
time: 1284115750
uid: 500

backtrace
-----
jobviewer.py:2080:_set_job_document_text:KeyError: 20

Traceback (most recent call last):
  File "/usr/share/system-config-printer/jobviewer.py", line 2080, in _set_job_document_text
    job = self.jobs[jobid]
KeyError: 20

Local variables in innermost frame:
column: <gtk.TreeViewColumn object at 0xb294ee64 (GtkTreeViewColumn at 0x8b34c10)>
self: <jobviewer.JobViewer instance at 0x8dde56c>
iter: <GtkTreeIter at 0xbfeb4898>
jobid: 20
cell: <gtk.CellRendererText object at 0xb2959234 (GtkCellRendererText at 0x8cb1278)>
model: <gtk.TreeStore object at 0x8de20a4 (GtkTreeStore at 0x8cae9d0)>
data: ()

Comment 1 Steven Haigh 2010-09-10 10:49:56 UTC
Created an attachment (id=446486)
File: backtrace

Comment 2 Jiri Popelka 2010-09-13 14:48:03 UTC
I'm not able to reproduce it.
Are you able to reproduce it ?
Can you better describe the 'Editing a printer via http://localhost:631' step ? thanks

Comment 3 Jiri Popelka 2010-09-13 14:48:46 UTC
Created attachment 446953 [details]
suggested patch

Comment 4 Tim Waugh 2010-09-13 15:07:23 UTC
If the TreeStore is getting out-of-sync with self.jobs there it would be better to fix that by: whenever a job is removed from self.jobs, make sure it is removed from the TreeStore first.  Otherwise we'll end up with a stale entry left on the screen.

That *ought* to be happening already, but it sounds like it isn't in one place or other.

Comment 5 Steven Haigh 2010-09-13 15:16:17 UTC
I'm not 110% sure what I did to make this happen. I was tinkering a lot with another bug at the time with ghostscript causing printing issues - however I will be testing this again later today - I'll see if I can get something more concrete.

That being said, even if I can't reproduce it, then its probably good that a fix is done anyhow :)

Comment 6 Tim Waugh 2011-04-13 12:21:51 UTC
Best guess at what happened:
 monitor ->
   job_added ->
     add_job ->
       update_job ->
         connection.getJobAttributes
       <- cups.IPPError

In this situation, update_job returns early before setting self.jobs[job], but add_job carries on and adds it to the TreeStore and to self.jobiters.

Should be fixed in 3038c9d.

Comment 7 Tim Waugh 2011-04-13 12:22:15 UTC
*** Bug 693055 has been marked as a duplicate of this bug. ***

Comment 8 Jiri Popelka 2011-05-30 13:52:57 UTC
*** Bug 708989 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2011-06-03 11:34:38 UTC
system-config-printer-1.3.3-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.3-1.fc15

Comment 10 Jiri Popelka 2011-06-03 13:23:04 UTC
*** Bug 710354 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2011-06-04 03:04:12 UTC
Package system-config-printer-1.3.3-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-printer-1.3.3-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-printer-1.3.3-1.fc15
then log in and leave karma (feedback).

Comment 12 Jiri Popelka 2011-06-21 09:34:29 UTC
*** Bug 714330 has been marked as a duplicate of this bug. ***

Comment 13 Tim Waugh 2011-06-21 10:01:27 UTC
Oh, this was never fixed on the 1.2.x branch by the look of it.  I've cherry-picked it now as 6c6aeda.

Comment 14 Fedora Update System 2011-06-21 17:12:16 UTC
system-config-printer-1.3.3-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-07-18 11:34:26 UTC
system-config-printer-1.3.4-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.4-1.fc15

Comment 16 Fedora Update System 2011-08-12 10:56:45 UTC
system-config-printer-1.3.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-08-12 18:18:04 UTC
system-config-printer-1.3.5-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2011-10-25 14:17:10 UTC
system-config-printer-1.2.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-printer-1.2.9-1.fc14

Comment 19 Fedora Update System 2011-11-04 20:29:25 UTC
system-config-printer-1.2.9-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.