Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 63257 - pdfTeX Type1 font embedding is broken
pdfTeX Type1 font embedding is broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: tetex (Show other bugs)
skipjack-beta2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-11 15:09 EDT by Tom Moertel
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 06:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kinder, gentler Type1 font embedding patch (11.49 KB, patch)
2002-04-11 15:11 EDT, Tom Moertel
no flags Details | Diff
Patch to RPM spec file (1.04 KB, patch)
2002-04-11 15:14 EDT, Tom Moertel
no flags Details | Diff

  None (edit)
Description Tom Moertel 2002-04-11 15:09:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020327

Description of problem:
When pdfTeX embeds Type 1 fonts into the PDF documents it creates, it does so in
a manner that, while theoretically allowable under the Type 1 spec, is "broken"
according to the friendly folks at Adobe.  The theoretical nature of this
breakage has become a physical reality in Adobe's revised Acrobat products. 
Using Acrobat Reader 5 to print a pdfTex-created document that contains embedded
Type1 fonts, for example, results in page barf when printed on a Postscript
printer.  (Luckily, a patch appeared a few months ago on the pdftex mailing
list, and it solves the problems.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Create a latex document that uses a Postscript font that is not one of the
standard "Adobe 13" built into PDF-reading products.  Use, for example, Utopia,
which comes with Red Hat Linux.
2.  Create a PDF file from the document via pdflatex.
3.  Open the document with Acrobat Reader 5 and print it to a Postscript printer.
4.  Marvel at the output's barf-like nature.
	

Actual Results:  Pages contain a horribly barf-like combination of type drawn
from the "Adobe 13" fonts.  Not Utopia.

Expected Results:  Pages, beautifully typeset in Utopia, reflect photons
lovingly into the eyes of the beholder.

Additional info:

Tom Kacvinsky posted a patch for this problem to the pdftex mailing list on 20
June 2001. http://www.tug.org/pipermail/pdftex/2001-June/001225.html  It's a
long thread.  You'll have to back up a few levels to read it all.

Bottom line: The patch works.  I added it to your tetex-1.0.7-45.src.rpm,
rebuilt the RPMs, and -- bazaam! -- all problems solved.

Note that the patch that Tom posted must be applied twice, once to each copy of
writet1.c in your pdftex-20010417.tgz tarball.  I simply duped the hunks in the
patch, and edited the headers so that the one patch would apply to both files.

I'll attach my doubled-up version of Tom's patch plus my patch to your .spec
file that incorporates the former.
Comment 1 Tom Moertel 2002-04-11 15:11:09 EDT
Created attachment 53484 [details]
Kinder, gentler Type1 font embedding patch
Comment 2 Tom Moertel 2002-04-11 15:14:39 EDT
Created attachment 53485 [details]
Patch to RPM spec file
Comment 3 Tim Waugh 2002-04-12 05:59:57 EDT
Thanks.  Fixed package is 1.0.7-47.

Note You need to log in before you can comment on or make changes to this bug.