Bug 632575 - DBusException: org.freedesktop.DBus.Error.AccessDenied: Interface "org.freedesktop.NetworkManager" isn't exported (or may not exist), can't access property "Devices"
DBusException: org.freedesktop.DBus.Error.AccessDenied: Interface "org.freede...
Status: CLOSED DUPLICATE of bug 626780
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
Unspecified Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:126218facf5777ace...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-10 09:25 EDT by Jayrome
Modified: 2011-01-22 10:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-10 10:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (158.05 KB, text/plain)
2010-09-10 09:26 EDT, Jayrome
no flags Details
Attached traceback automatically from anaconda. (157.88 KB, text/plain)
2010-09-10 10:37 EDT, Misha Shnurapet
no flags Details
Attached traceback automatically from anaconda. (126.99 KB, text/plain)
2010-10-06 05:32 EDT, Ray Evans
no flags Details
Attached traceback automatically from anaconda. (157.57 KB, text/plain)
2010-10-09 16:25 EDT, Ray Evans
no flags Details
Attached traceback automatically from anaconda. (550.74 KB, text/plain)
2011-01-22 10:28 EST, Flóki Pálsson
no flags Details

  None (edit)
Description Jayrome 2010-09-10 09:25:58 EDT
The following was filed automatically by anaconda:
anaconda 13.42 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/anaconda/network.py", line 86, in getDefaultHostname
    devices = active_connection_props_iface.Get(isys.NM_MANAGER_IFACE, 'Devices')
  File "/usr/lib/anaconda/iw/network_gui.py", line 37, in getScreen
    self.hostname = network.getDefaultHostname(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1393, in setScreen
    new_screen = self.currentWindow.getScreen(anaconda)
  File "/usr/lib/anaconda/gui.py", line 1314, in nextClicked
    self.setScreen ()
DBusException: org.freedesktop.DBus.Error.AccessDenied: Interface "org.freedesktop.NetworkManager" isn't exported (or may not exist), can't access property "Devices"
Comment 1 Jayrome 2010-09-10 09:26:05 EDT
Created an attachment (id=446513)
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2010-09-10 09:56:15 EDT
Is this using a rebuild of Fedora 13?
Comment 3 Misha Shnurapet 2010-09-10 10:37:02 EDT
Created an attachment (id=446525)
Attached traceback automatically from anaconda.
Comment 4 Misha Shnurapet 2010-09-10 10:42:18 EDT
(In reply to comment #2)
> Is this using a rebuild of Fedora 13?
This is the LiveCD respin.
Comment 5 Chris Lumens 2010-09-10 10:48:11 EDT

*** This bug has been marked as a duplicate of bug 626780 ***
Comment 6 Ray Evans 2010-10-06 05:32:33 EDT
Created attachment 451846 [details]
Attached traceback automatically from anaconda.
Comment 7 Ray Evans 2010-10-09 16:25:57 EDT
Created attachment 452547 [details]
Attached traceback automatically from anaconda.
Comment 8 Flóki Pálsson 2011-01-22 10:28:09 EST
Created attachment 474739 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.