Bug 632685 - firstboot isn't run on Beta TC1 install
firstboot isn't run on Beta TC1 install
Status: CLOSED DUPLICATE of bug 628241
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-09-10 14:11 EDT by Brian Lane
Modified: 2013-07-04 08:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-11 18:11:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2010-09-10 14:11:30 EDT
Description of problem:
Firstboot doesn't run

Version-Release number of selected component (if applicable):
firstboot-1.112-3.fc14.x86_64


Steps to Reproduce:
1. Install F14 Beta TC1 from DVD

/etc/init.d/firstboot exists, but chkconfig --list firstboot says it isn't referenced in any runlevel. With the change to systemd I'm not sure if that's the correct utility to use or not.
Comment 1 Brian Lane 2010-09-10 14:34:57 EDT
I hit alt-f6 and firstboot was there. I then accidentally hit alt-f4 (instead of ctrl-alt-f4) and the screen went to back and no amount of alt or ctrl-alt would get me to a console or firstboot.

I hard-booted, and now gdm is on tty1 with consoles on 2-6 and no firstboot.

Maybe firstboot is confused about which tty to use since gdm is now on tty1 instead of 6.
Comment 2 James Laska 2010-09-10 15:20:52 EDT
It looks like Martin may already have a firstboot update that may address some of the issues you note.

Any chance you could re-test with the firstboot in updates-testing?

https://admin.fedoraproject.org/updates/firstboot-1.113-1.fc14
Comment 3 Adam Williamson 2010-09-11 18:11:12 EDT
almost certainly another case of 628241. we know that firstboot is broken.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 628241 ***

Note You need to log in before you can comment on or make changes to this bug.