Bug 632712 - PXE Boot Fails with virtio NIC
PXE Boot Fails with virtio NIC
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.0
All Linux
high Severity medium
: beta
: 6.1
Assigned To: Glauber Costa
Virtualization Bugs
: Reopened
: 632716 (view as bug list)
Depends On:
Blocks: 580954
  Show dependency treegraph
 
Reported: 2010-09-10 15:32 EDT by Gordan Bobic
Modified: 2013-01-09 18:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-02 09:23:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gordan Bobic 2010-09-10 15:32:18 EDT
Description of problem:
If the VM NIC is virtio based, PXE boot fails. e1000 works OK, though.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.90.el6.x86_64

How reproducible:
Every time.

Steps to Reproduce:
1. Create an empty VM, set RHEL6 as the VM type
2. Try to PXE boot via a bridged interface
  
Actual results:
For virtion:
gPXE> dhcp net0
DHCP (net0 52:54:00:56:4e:1f)................ Connection timed out (0x4c106035)
Could not configure net0: Connection timed out (0x4c106035)

However, setting it to e1000:
gPXE> dhcp net0
DHCP (net0 52:54:00:56:4e:1f)................ ok
gPXE>


Expected results:
Should work for both virtio and emulated NICs.
Comment 2 Amit Shah 2010-10-15 06:20:57 EDT
Is this bug related to bug 632716?
Comment 3 Gordan Bobic 2010-10-15 06:34:08 EDT
I don't think they are related per se. This is about DHCP failing. https://bugzilla.redhat.com/show_bug.cgi?id=632716 is about the tftp boot failing. This is lower level than that.
Comment 4 Amit Shah 2010-10-15 06:45:04 EDT
(In reply to comment #3)
> I don't think they are related per se. This is about DHCP failing.
> https://bugzilla.redhat.com/show_bug.cgi?id=632716 is about the tftp boot
> failing. This is lower level than that.

Ah, I see now.  This is due to the bridge delay.  Glauber, Dan, any ideas how to resolve this?
Comment 5 Daniel Berrange 2010-10-15 06:55:40 EDT
There's not enough information here really.

Please provide the full libvirt XML for the guest, and the corresponding /var/log/libvirt/qemu/$GUEST.log file

Also provide info on the host networking setup from

  ifconfig -a
  brctl show
  brctl showstp $BRIDGENAME
  sysctl -a | grep ip_forward
  iptables -L -n -v
  iptables -t nat -L -n -v

Finally what libvirt RPM version is present.
Comment 6 Andrew McNabb 2010-11-18 20:35:00 EST
Is this a duplicate of bug #586324?
Comment 7 Gordan Bobic 2010-11-20 06:34:03 EST
Yes, it looks like it is!
Setting DELAY=0 in the ifcfg-br0 config file solves the problem.
Comment 8 Bill Burns 2010-11-20 08:12:18 EST
Closed as a dup per previous comments.

*** This bug has been marked as a duplicate of bug 586324 ***
Comment 9 Bill Burns 2010-11-20 08:19:17 EST
Oops other bug is a Fedora bug. Will leave this RHEL bug assigned.
Comment 11 Glauber Costa 2011-03-02 09:26:01 EST
*** Bug 632716 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.