Bug 632714 - console-kit-log-system-start.service fails to start at boot
Summary: console-kit-log-system-start.service fails to start at boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ConsoleKit
Version: 14
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-10 19:45 UTC by Stefan Becker
Modified: 2010-09-15 07:14 UTC (History)
6 users (show)

Fixed In Version: ConsoleKit-0.4.2-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-15 07:14:51 UTC


Attachments (Terms of Use)

Description Stefan Becker 2010-09-10 19:45:50 UTC
Description of problem:

Not sure if this is a big problem. But when I look at

   systemctl --all --full | grep failed

after boot I see that this service failed with exit code 1:

# systemctl status console-kit-log-system-start.service
console-kit-log-system-start.service - Console System Startup Logging
          Loaded: loaded (/lib/systemd/system/console-kit-log-system-start.service)
          Active: failed since [Fri, 10 Sep 2010 22:24:39 +0300; 7min ago]
         Process: 439 (/usr/sbin/ck-log-system-start, code=exited, status=1/FAILURE)
          CGroup: name=systemd:/systemd-1/console-kit-log-system-start.service


But I can restart it (at least when I'm logged into my KDE session):

# systemctl restart console-kit-log-system-start.service
# systemctl status console-kit-log-system-start.service
console-kit-log-system-start.service - Console System Startup Logging
          Loaded: loaded (/lib/systemd/system/console-kit-log-system-start.service)
          Active: active (exited) since [Fri, 10 Sep 2010 22:36:46 +0300; 3s ago]
         Process: 1995 (/usr/sbin/ck-log-system-start, code=exited, status=0/SUCCESS)
          CGroup: name=systemd:/systemd-1/console-kit-log-system-start.service


Maybe the dependencies are wrong?

/lib/systemd/system/console-kit-log-system-start.service
Before=poweroff.service reboot.service halt.service killall.service
After=local-fs.target


Version-Release number of selected component (if applicable):
ConsoleKit-0.4.2-1.fc14.i686
systemd-9-3.fc14.i686
systemd-sysvinit-9-3.fc14.i686
systemd-units-9-3.fc14.i686
initscripts-9.20-1.fc14.i686

How reproducible: Always

Comment 1 Bill Nottingham 2010-09-10 19:54:34 UTC
It's trying to start this way too soon... if you'll see the messages fly by, it happens right after init is started.

Either local-fs.target is being achieved too early, or the dependencies should be switched to be After: sysinit.target.

Comment 2 Stefan Becker 2010-09-10 21:33:34 UTC
(In reply to comment #1)
> Either local-fs.target is being achieved too early, or the dependencies should
> be switched to be After: sysinit.target.

That change fixed the problem. So ConsoleKit needs to be updated?

Comment 3 Lennart Poettering 2010-09-13 14:45:13 UTC
After=fsck.target is missing here I guess. I'll fix the CK package.

Comment 4 Fedora Update System 2010-09-14 02:28:55 UTC
ConsoleKit-0.4.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ConsoleKit-0.4.2-2.fc14

Comment 5 Fedora Update System 2010-09-14 04:29:47 UTC
ConsoleKit-0.4.2-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ConsoleKit'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/ConsoleKit-0.4.2-2.fc14

Comment 6 Fedora Update System 2010-09-15 07:14:46 UTC
ConsoleKit-0.4.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.