Bug 632818 - Graphical login impossible after update to "1:gdm-2.31.90-5.fc14.i686" in F14
Graphical login impossible after update to "1:gdm-2.31.90-5.fc14.i686" in F14
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 632886 (view as bug list)
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-09-11 03:05 EDT by Joachim Backes
Modified: 2015-01-14 18:26 EST (History)
21 users (show)

See Also:
Fixed In Version: gdm-2.31.90-6.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 03:06:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog from first "gdm" line through first traceback (41.46 KB, text/plain)
2010-09-12 15:25 EDT, John Reiser
no flags Details

  None (edit)
Description Joachim Backes 2010-09-11 03:05:53 EDT
Description of problem:
Applying the most recent updates (including 1:gdm-2.31.90-5.fc14.i686)
prevents from a graphical login: The gdm greeter is blinking in some
manner, no login pictures are shown, unable to select user.

Could go back to a stable login by downgrading to gdm-2.31.90-4.fc14.i686.


Version-Release number of selected component (if applicable):

1:gdm-2.31.90-5.fc14.i686
How reproducible:

always
Steps to Reproduce:
1.See description
2.
3.
  
Actual results:

See description

Expected results:


Additional info:
Comment 1 Mirco Tischler 2010-09-11 08:45:15 EDT
I can confirm this bug. It seems like everytime the login screen "blinks", a new gdm-session-worker process is spawned. After a few minutes I got hundreds of them.
Comment 2 Steve Tyler 2010-09-11 09:53:59 EDT
Confirmed too.
Recovered from a console:
# yum downgrade gdm gdm-plugin-fingerprint
# reboot

[root@cedar log]# grep gdm yum.log
Sep 02 12:12:17 Updated: plymouth-gdm-hooks-0.8.4-0.20100823.4.fc14.x86_64
Sep 08 08:38:23 Updated: 1:gdm-2.31.90-4.fc14.x86_64
Sep 08 08:38:45 Updated: 1:gdm-plugin-fingerprint-2.31.90-4.fc14.x86_64
Sep 08 08:38:46 Updated: 1:gdm-user-switch-applet-2.31.90-4.fc14.x86_64
Sep 11 06:32:54 Updated: 1:gdm-2.31.90-5.fc14.x86_64
Sep 11 06:33:18 Updated: 1:gdm-user-switch-applet-2.31.90-5.fc14.x86_64
Sep 11 06:33:19 Updated: 1:gdm-plugin-fingerprint-2.31.90-5.fc14.x86_64
Sep 11 06:42:22 Installed: 1:gdm-2.31.90-1.fc14.x86_64
Sep 11 06:42:22 Installed: 1:gdm-plugin-fingerprint-2.31.90-1.fc14.x86_64
Comment 3 Nils Philippsen 2010-09-11 12:27:01 EDT
I have the same issue with this version. I'll try out downgrading to -4.
Comment 4 Nils Philippsen 2010-09-11 12:32:33 EDT
Downgrading to -4, then killing all remaining gdm-related processes (e.g. lots of "pam: gdm-password") let me login again.
Comment 5 Aaron Sowry 2010-09-12 07:13:45 EDT
Confirming same problem here. Severity should perhaps be upgraded and bug 632886 marked as a duplicate of this one.
Comment 6 John Reiser 2010-09-12 15:25:04 EDT
Created attachment 446795 [details]
syslog from first "gdm" line through first traceback

gdm-simple-greeter[1338]: GLib-CRITICAL: g_markup_escape_text: assertion `text != NULL' failed#012aborting...

Captured syslog from first "gdm" line after boot, through end of first traceback; 558 lines total.  After that there were hundreds of apparent repetitions.  Configuration was:
gdm-2.31.90-5.fc14.x86_64
gdm-plugin-fingerprint-2.31.90-5.fc14.x86_64
gdm-user-switch-applet-2.31.90-5.fc14.x86_64
plymouth-gdm-hooks-0.8.4-0.20100823.4.fc14.x86_64
pulseaudio-gdm-hooks-0.9.21-6.fc13.x86_64
Comment 7 Bastien Nocera 2010-09-13 06:32:16 EDT
Slightly different backtrace from me. This also only happens with 2.31.90-5, 2.31.90-4 works well.

Sep 13 11:16:29 cookie gdm-simple-greeter[9775]: CRITICAL: _gdm_user_update_login_frequency: assertion `GDM_IS_USER (user)' failed#012aborting...
Sep 13 11:16:29 cookie gdm[9788]: ******************* START **********************************
Sep 13 11:16:29 cookie gdm[9788]: [Thread debugging using libthread_db enabled]
Sep 13 11:16:29 cookie gdm[9788]: [New Thread 0x7f265734e710 (LWP 9777)]
Sep 13 11:16:29 cookie gdm[9788]: [New Thread 0x7f2657b4f710 (LWP 9776)]
Sep 13 11:16:31 cookie gdm[9788]: 0x000000342bc0ef5d in __libc_waitpid (pid=<value optimized out>, stat_loc=<value optimized out>, options=<value optimized out>) at ../sysdeps/unix/sysv/linux/waitpid.c:41
Sep 13 11:16:31 cookie gdm[9788]: 41#011  int result = INLINE_SYSCALL (wait4, 4, pid, stat_loc, options, NULL);
Sep 13 11:16:31 cookie gdm[9788]: #0  0x000000342bc0ef5d in __libc_waitpid (pid=<value optimized out>, stat_loc=<value optimized out>, options=<value optimized out>) at ../sysdeps/unix/sysv/linux/waitpid.c:41
Sep 13 11:16:31 cookie gdm[9788]: #1  0x0000000000432c1b in crashlogger_get_backtrace () at gdm-signal-handler.c:196
Sep 13 11:16:31 cookie gdm[9788]: #2  gdm_signal_handler_backtrace () at gdm-signal-handler.c:223
Sep 13 11:16:31 cookie gdm[9788]: #3  0x0000000000432cca in signal_handler (signo=<value optimized out>) at gdm-signal-handler.c:251
Sep 13 11:16:31 cookie gdm[9788]: #4  <signal handler called>
Sep 13 11:16:31 cookie gdm[9788]: #5  g_logv (log_domain=0x0, log_level=<value optimized out>, format=0x342b0ad0b8 "%s: assertion `%s' failed", args1=0x7fff1a1ca340) at gmessages.c:554
Sep 13 11:16:31 cookie gdm[9788]: #6  0x000000342b04c063 in g_log (log_domain=<value optimized out>, log_level=<value optimized out>, format=<value optimized out>) at gmessages.c:568
Sep 13 11:16:31 cookie gdm[9788]: #7  0x000000000043a052 in process_ck_history_line (source=<value optimized out>, condition=<value optimized out>, manager=0x125be60) at gdm-user-manager.c:1744
Sep 13 11:16:31 cookie gdm[9788]: #8  ck_history_watch (source=<value optimized out>, condition=<value optimized out>, manager=0x125be60) at gdm-user-manager.c:1805
Sep 13 11:16:31 cookie gdm[9788]: #9  0x000000342b043233 in g_main_dispatch (context=0x11592c0) at gmain.c:2119
Sep 13 11:16:31 cookie gdm[9788]: #10 g_main_context_dispatch (context=0x11592c0) at gmain.c:2672
Sep 13 11:16:31 cookie gdm[9788]: #11 0x000000342b043a10 in g_main_context_iterate (context=0x11592c0, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2750
Sep 13 11:16:31 cookie gdm[9788]: #12 0x000000342b044082 in g_main_loop_run (loop=0x141e2b0) at gmain.c:2958
Sep 13 11:16:31 cookie gdm[9788]: #13 0x000000343494ac67 in IA__gtk_main () at gtkmain.c:1237
Sep 13 11:16:31 cookie gdm[9788]: #14 0x0000000000413224 in main (argc=1, argv=0x7fff1a1ca788) at greeter-main.c:314
Sep 13 11:16:31 cookie gdm[9788]: 
Sep 13 11:16:31 cookie gdm[9788]: Thread 3 (Thread 0x7f2657b4f710 (LWP 9776)):
Sep 13 11:16:31 cookie gdm[9788]: #0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:216
Sep 13 11:16:31 cookie gdm[9788]: No locals.
Sep 13 11:16:31 cookie gdm[9788]: #1  0x000000342d4023c2 in g_cond_timed_wait_posix_impl (cond=<value optimized out>, entered_mutex=<value optimized out>, abs_time=<value optimized out>) at gthread-posix.c:242
Sep 13 11:16:31 cookie gdm[9788]:         result = <value optimized out>
Sep 13 11:16:31 cookie gdm[9788]: 
Sep 13 11:16:31 cookie gdm[9788]:         timed_out = <value optimized out>
Sep 13 11:16:31 cookie gdm[9788]: 
Sep 13 11:16:31 cookie gdm[9788]: #2  0x000000342b017b1f in g_async_queue_pop_intern_unlocked (queue=0x1212ef0, try=0, end_time=0x7f2657b4ec70) at gasyncqueue.c:423
Sep 13 11:16:31 cookie gdm[9788]:         retval = <value optimized out>
Sep 13 11:16:31 cookie gdm[9788]: 
Sep 13 11:16:31 cookie gdm[9788]: #3  0x000000342b018517 in g_async_queue_timed_pop (queue=0x1212ef0, end_time=0x7f2657b4ec70) at gasyncqueue.c:549
Sep 13 11:16:31 cookie gdm[9788]:         retval = <value optimized out>
Comment 8 Bastien Nocera 2010-09-13 06:37:49 EDT
*** Bug 632886 has been marked as a duplicate of this bug. ***
Comment 9 Ray Strode [halfline] 2010-09-13 09:45:29 EDT
sorry about that guys, I guess when I did non-accounts-service fixes I introduced an assertion failure in the accounts service code path. I'm looking into it now.
Comment 10 Fedora Update System 2010-09-13 10:40:32 EDT
gdm-2.31.90-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gdm-2.31.90-6.fc14
Comment 11 Joachim Backes 2010-09-13 10:59:26 EDT
Heureka! Runs for me!
Comment 12 Mirco Tischler 2010-09-13 11:08:23 EDT
Yup. Fix confirmed. Thanks
Comment 13 Steve Tyler 2010-09-13 14:51:11 EDT
Graphical login is possible with:
gdm-2.31.90-6.fc14.x86_64
gdm-plugin-fingerprint-2.31.90-6.fc14.x86_64
gdm-user-switch-applet-2.31.90-6.fc14.x86_64
Comment 14 Fedora Update System 2010-09-15 03:06:06 EDT
gdm-2.31.90-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.