Bug 63291 - xemacs's browse-url passes -x to galeon
Summary: xemacs's browse-url passes -x to galeon
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: xemacs (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-12 03:40 UTC by Jens Petersen
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 21:22:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to browse-url.el: only pass --existing to galeon when not using new-window (651 bytes, patch)
2002-04-12 03:51 UTC, Jens Petersen
no flags Details | Diff
the right patch (587 bytes, patch)
2002-04-12 04:28 UTC, Jens Petersen
no flags Details | Diff

Description Jens Petersen 2002-04-12 03:40:37 UTC
Description of Problem:
-x (--existing) shouldn't be passed to galeon since it overrides
--new-tab.

How Reproducible:
every time

Steps to Reproduce:
0. start browsing in galeon with tabs enabled
1. start a vanilla xemacs
2. eval
(setq browse-url-browser-function 'browse-url-galeon
      browse-url-galeon-new-window-is-tab t
      browse-url-new-window-flag t)
3. enter http://www.redhat.com, leaving point at end of url
4. M-x browse-url RET RET

Actual Results:
The page given comes up in the current tab.

Expected Results:
The page should come up in a new tab.

Additional Information:
The attached patch fixes the problem.

Comment 1 Jens Petersen 2002-04-12 03:51:33 UTC
Created attachment 53564 [details]
patch to browse-url.el: only pass --existing to galeon when not using new-window

Comment 2 Jens Petersen 2002-04-12 03:54:13 UTC
To clarify, --existing should only to passed when
browse-url-new-window-flag nil.  The patch I attached does that.

Comment 3 Jens Petersen 2002-04-12 04:28:24 UTC
Created attachment 53565 [details]
the right patch

Comment 4 Trond Eivind Glomsrxd 2002-04-12 15:02:30 UTC
Sounds like a good thing to go in upstream :)

Comment 5 Jens Petersen 2002-04-15 07:08:45 UTC
Yep.  Simon Josefsson told me he already committed a fix into
xemacs-package cvs.  It's very annoying though, so I wouldn't mind
putting a placeholder patch into our xemacs until it appears in our
sumo.  If you don't object, you can assign this bug to me. :)


Comment 6 Trond Eivind Glomsrxd 2002-07-25 23:39:30 UTC
Packages have been updated, and the sumo packages from 2002-07-20 are included
in xemacs-21.4.8-10

Comment 7 Jens Petersen 2002-07-31 07:12:17 UTC
Confirmed fixed.


Note You need to log in before you can comment on or make changes to this bug.