Bug 632918 - Can't use virt-resize on Ubuntu 10.04 image
Can't use virt-resize on Ubuntu 10.04 image
Status: CLOSED DUPLICATE of bug 642821
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-11 17:49 EDT by Richard W.M. Jones
Modified: 2010-10-16 09:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-16 09:36:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2010-09-11 17:49:48 EDT
Description of problem:

# virt-resize --expand /dev/sda1 /dev/vg_trick/Ubuntu1004x64P /dev/vg_trick/Ubuntu1010betax64
part_get_bootable: partition number out of range: 5 at /usr/bin/virt-resize line 613.

It seems that virt-resize is confused by the extended partition:

# virt-list-filesystems /dev/vg_trick/Ubuntu1004x64P -al
/dev/sda1 ext4
/dev/sda5 swap


Version-Release number of selected component (if applicable):

1.5.12
Comment 1 Richard W.M. Jones 2010-10-16 09:36:34 EDT

*** This bug has been marked as a duplicate of bug 642821 ***

Note You need to log in before you can comment on or make changes to this bug.