Bug 63292 - ether_ntohost causes segfault
Summary: ether_ntohost causes segfault
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: skipjack-beta2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-12 03:44 UTC by Mark Salter
Modified: 2016-11-24 15:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 03:44:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark Salter 2002-04-12 03:44:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The ether_ntohost() function causes a segfault. It looks like it is being
miscompiled. Looking at the source, it calls __nss_ethers_lookup(), but when
disassembled in gdb, it is actually calling __nss_passwd_lookup().

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run "tcpdump -i eth0" or any app calling ether_ntohost().
2.
3.
	

Actual Results:  segfault

Expected Results:  No segfault.

Additional info:

This app demonstrates problem:

main()
{
    unsigned char addr[6] = { 0xff, 0xff, 0xff, 0xff, 0xff, 0xff };
    char name[256];
    ether_ntohost(name, addr);
}

Comment 1 Jakub Jelinek 2002-04-12 08:02:14 UTC
This was fixed in glibc-2.2.5-32.


Note You need to log in before you can comment on or make changes to this bug.