Bug 632926 - auditd bumps into "deprecated" complaints
Summary: auditd bumps into "deprecated" complaints
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audit
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 711753 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-12 00:26 UTC by Michal Jaegermann
Modified: 2011-07-31 03:53 UTC (History)
7 users (show)

Fixed In Version: audit-2.1.2-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-21 17:27:33 UTC
Type: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2010-09-12 00:26:14 UTC
Description of problem:

The following shows up in dmesg for various rawhide kernels:

auditd (1676): /proc/1676/oom_adj is deprecated, please use /proc/1676/oom_score_adj instead.

Version-Release number of selected component (if applicable):
audit-2.0.4-4.fc14
kernel-2.6.36-0.18.rc3.git1.fc15.x86_64 (and not only).

Additional information:
Nothing of that sort noticed on Fedora 13 installations using audit-2.0.4-3.fc13.

Comment 1 Daniel Mach 2011-02-28 09:10:05 UTC
The same message found on F15.

Comment 2 Magnus Glantz 2011-06-04 18:18:13 UTC
I also hit this on F15.

$ dmesg|grep audit
[    1.373137] audit: initializing netlink socket (disabled)
[    1.373147] type=2000 audit(1307218444.112:1): initialized
[   13.051767] type=1404 audit(1307218456.596:2): enforcing=1 old_enforcing=0 auid=4294967295 ses=4294967295
[   13.611123] type=1403 audit(1307218457.156:3): policy loaded auid=4294967295 ses=4294967295
[   36.145743] auditd (972): /proc/972/oom_adj is deprecated, please use /proc/972/oom_score_adj instead.

$ rpm -q audit; uname -a
audit-2.1.1-1.fc15.x86_64
Linux blue1.localdomain 2.6.38.6-27.fc15.x86_64 #1 SMP Sun May 15 17:23:28 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Comment 3 Steve Grubb 2011-06-05 00:14:24 UTC
This was put in upstream svn last month:
https://fedorahosted.org/audit/changeset/537

It will be in 2.1.2 which I expect to release in a week or two.

Comment 4 Steve Grubb 2011-06-08 14:00:34 UTC
*** Bug 711753 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2011-06-11 15:26:29 UTC
audit-2.1.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/audit-2.1.2-1.fc15

Comment 6 Fedora Update System 2011-06-15 05:32:22 UTC
Package audit-2.1.2-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing audit-2.1.2-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/audit-2.1.2-1.fc15
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2011-06-21 17:27:27 UTC
audit-2.1.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.