Bug 633042 - KVM : after live migration attached CD will be reloaded on to the CDROM
KVM : after live migration attached CD will be reloaded on to the CDROM
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5.z
All Linux
high Severity high
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
: Reopened, Triaged
: 578751 (view as bug list)
Depends On:
Blocks: Rhel5KvmTier2 Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2010-09-12 11:13 EDT by yeylon@redhat.com
Modified: 2016-04-18 02:34 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
RHEL5.5.Z kvm-debuginfo-83-164.el5_5.23 kvm-83-164.el5_5.23 kmod-kvm-83-164.el5_5.23 kvm-tools-83-164.el5_5.23 kvm-qemu-img-83-164.el5_5.23
Last Closed: 2011-08-07 06:57:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screendump (203.30 KB, image/png)
2011-05-12 05:36 EDT, Mike Cao
no flags Details

  None (edit)
Description yeylon@redhat.com 2010-09-12 11:13:29 EDT
Description of problem:

migrate a VM with attached CD.
at the end of the migration the CD will be reloaded in to the VM once again.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. attach a CD to the VM
2. migrate the VM (with the CDROM window opened)
3. check the VM at the end of that the window will be closed and reopen
  
Actual results:


Expected results:


Additional info:

due to this occurs in qemu level no logs are being added
Comment 2 Markus Armbruster 2010-09-13 04:27:17 EDT
I'm not sure I understand the problem description.  Is it about migrating while the virtual CD drives tray is open?  

If no, please explain.

If yes, is the following a fair interpretation of your steps to reproduce?

1. Make sure VM has a virtual CD drive with media.
2. Open its tray.
3. Migrate the VM.
4. Check whether the tray is still open.

If these are not the correct steps, please describe correct steps.

Regardless, please describe actual and expected results.
Comment 4 Jes Sorensen 2011-01-17 05:59:48 EST
Yaniv,

Could you please provide the data requested by Markus? This bug has
been stuck in needinfo for 4 months now.

Thanks,
Jes
Comment 7 Juan Quintela 2011-01-19 09:18:23 EST
Problem is:
- start install on VM A with a cdrom
- half through the install migrate to machine B
- installer will told you next time that it tries to
  access the cdrom that cdrom is empty
- you press "yes" to say that you have inserted the cdrom

and things continue as expected.  Is just the dialog that shouldn't be there.
I have reproduced it with the installation of Windows 7.
Comment 8 Shaolong Hu 2011-01-28 03:55:00 EST
Reproduce on kvm-83-224.el5

Guest info: RHEL5.5-Server-20100322

Step:
1. In qemu-kvm command, attach iso with -cdrom xxx.iso
2. In guest, open the window of cdrom
3. Migrate

Actual Results:
1. After migration, in the destiny guest, cdrom window closes automatically.
2. Need to mount /dev/cdrom manually to use the cdrom again.
Comment 9 Juan Quintela 2011-02-16 06:44:05 EST
*** Bug 578751 has been marked as a duplicate of this bug. ***
Comment 10 Juan Quintela 2011-02-16 06:47:37 EST
*** Bug 666225 has been marked as a duplicate of this bug. ***
Comment 13 Glauber Costa 2011-05-10 16:11:14 EDT

*** This bug has been marked as a duplicate of bug 652135 ***
Comment 14 Mike Cao 2011-05-12 05:35:32 EDT
Re-assigned this issue due to it is not same bug with bug 652135
hit the issue on 
# uname -r
2.6.18-260.el5
# rpm -q kvm
kvm-83-232.el5

steps .
1.start guest with cdrom
eg:/usr/libexec/qemu-kvm -M rhel5.6.0 -m 4G -smp 4,sockets=4,cores=1,threads=1 -name VM -uuid 02b8079c-cca0-ae65-c63a-a2aa4119497d -monitor stdio -no-kvm-pit-reinjection -usbdevice tablet -startdate now -boot dc -drive file=/dev/mike_cao/2_RHEL6u1_i386.qcow2,if=virtio,format=qcow2,werror=stop,cache=none,boot=on -net nic,macaddr=54:52:40:33:4c:58,vlan=0,model=virtio -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -usb -spice ic=on,host=0,port=5910,disable-ticketing -qxl 1 -k en-us -balloon none -notify all -no-hpet -drive file=/mnt/RHEL6.1-20110504.0-Server-i386-DVD1.iso,if=ide,format=raw,media=cdrom,cache=none
2.during the step guest copy files from cdrom to disk .do ping-pong migration

Actual Results:
After migration,installation failed .referring to screendump.
Comment 15 Mike Cao 2011-05-12 05:36:42 EDT
Created attachment 498493 [details]
screendump
Comment 16 Mike Cao 2011-05-12 06:00:25 EDT
Also hit the issue that 
do live migration during guest formating vdisks.

after installation failed .
#dmesg in the guest

sr 0:0:0:0: [sr0] Media Changed
sr 0:0:0:0: [sr0] Results:hostbyte=DID_OK driverbyte=DRIVER_SENSE
sr 0:0:0:0: [sr0] Sense key :Unit Attention [current]
sr 0:0:0:0: [sr0] Add. Sense: Not ready to ready change ,medium may have changed
sr 0:0:0:0: [sr0] CDB: Read(10) 20 00 00 16 d2 16 00 00 10 00
end_request: I/O error ,dev sr0 sector 5982296
Buffer I/O error on device sr0, logical block 1495574
Buffer I/O error on device sr0, logical block 1495575
...

Buffer I/O error on device sr0, logical block 1495582
Comment 17 Juan Quintela 2011-05-12 09:29:52 EDT
Could you double check that you are also using latest kvm package on destination host?  This is exactly the bug that we fixed.
Comment 18 Mike Cao 2011-05-12 22:09:23 EDT
(In reply to comment #17)
> Could you double check that you are also using latest kvm package on
> destination host?  This is exactly the bug that we fixed.

yes ,both hosts are using 
# uname -r
2.6.18-260.el5
# rpm -q kvm
kvm-83-232.el5

Hi,Juan

Could you tell me which patch(es) fixed this bug ?

Best Regards,
Mike

Note You need to log in before you can comment on or make changes to this bug.