Bug 633047 - [abrt] telepathy-sunshine-0.1.8-1.fc13: group.py:52:create_group:RuntimeError: dictionary changed size during iteration
Summary: [abrt] telepathy-sunshine-0.1.8-1.fc13: group.py:52:create_group:RuntimeError...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-sunshine
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Julian Sikorski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5e5c4e3f
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-12 15:32 UTC by Michal Klich
Modified: 2011-06-09 00:02 UTC (History)
3 users (show)

Fixed In Version: telepathy-sunshine-0.2.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-04 03:02:56 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (860 bytes, text/plain)
2010-09-12 15:32 UTC, Michal Klich
no flags Details

Description Michal Klich 2010-09-12 15:32:48 UTC
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/bin/python /usr/libexec/telepathy-sunshine
comment: It does not happen always, i believe that it may only happen when i add more than one contact. Unfortunately i am not sure.
component: telepathy-sunshine
executable: /usr/libexec/telepathy-sunshine
kernel: 2.6.34.6-54.fc13.x86_64
package: telepathy-sunshine-0.1.8-1.fc13
reason: group.py:52:create_group:RuntimeError: dictionary changed size during iteration
release: Fedora release 13 (Goddard)
time: 1284305341
uid: 500

backtrace
-----
group.py:52:create_group:RuntimeError: dictionary changed size during iteration

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/sunshine/util/decorator.py", line 130, in async_function
    func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/sunshine/channel/group.py", line 52, in create_group
    for group in self.conn.profile.groups:
RuntimeError: dictionary changed size during iteration

Local variables in innermost frame:
group: <sunshine.lqsoft.pygadu.models.GaduContactGroup object at 0x2775a90>
name: dbus.String(u'liceum')
g: <sunshine.lqsoft.pygadu.models.GaduContactGroup object at 0x280d350>
h: <md5 HASH object @ 0x28022b8>
self: <sunshine.channel.group.SunshineGroupChannel at /org/freedesktop/Telepathy/Connection/sunshine/gadugadu/_35672780/channel5 at 0x280ae50>
group_xml: <Element Group at 2802518>

How to reproduce
-----
1. Add new gadugadu contact
2. Change alias
3.

Comment 1 Michal Klich 2010-09-12 15:32:51 UTC
Created an attachment (id=446766)
File: backtrace

Comment 2 lejeczek 2010-09-13 18:53:44 UTC
Package: telepathy-sunshine-0.1.8-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. configure a GG account
2. add a contact
3. expect a crash

Comment 3 Krzysztof Klinikowski 2010-09-13 19:01:24 UTC
Could you check is that bug occurs in sunshine from GIT: git://git.collabora.co.uk/git/telepathy-sunshine.git ?

Comment 4 Julian Sikorski 2010-09-13 19:22:25 UTC
Hold on, I'll upload a package

Comment 5 Julian Sikorski 2010-09-13 19:28:32 UTC
Here it is, latest git code packaged:

http://belegdol.fedorapeople.org/telepathy-sunshine-0.1.8-7.fc13.noarch.rpm

Comment 6 Julian Sikorski 2010-10-10 21:54:27 UTC
While I was able to reproduce it a while ago, the problem seems to be gone now - which might indicate it was fixed by an update to some other package. Can you please test again?

Comment 7 Julian Sikorski 2010-10-10 21:58:57 UTC
And here's the latest git code package:
http://belegdol.fedorapeople.org/telepathy-sunshine-0.1.8-8.fc13.noarch.rpm

Comment 8 Michal Klich 2010-10-11 20:21:04 UTC
I could not reproduce it for while now. Tried povided package and still no luck so it is good.

Comment 9 Fedora Update System 2011-05-29 22:09:49 UTC
telepathy-sunshine-0.2.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/telepathy-sunshine-0.2.0-1.fc15

Comment 10 Fedora Update System 2011-05-29 22:14:04 UTC
telepathy-sunshine-0.2.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/telepathy-sunshine-0.2.0-1.fc14

Comment 11 Fedora Update System 2011-05-29 22:16:33 UTC
telepathy-sunshine-0.2.0-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/telepathy-sunshine-0.2.0-1.fc13

Comment 12 Fedora Update System 2011-05-30 22:26:53 UTC
Package telepathy-sunshine-0.2.0-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing telepathy-sunshine-0.2.0-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/telepathy-sunshine-0.2.0-1.fc15
then log in and leave karma (feedback).

Comment 13 Bug Zapper 2011-05-31 13:44:12 UTC
This message is a reminder that Fedora 13 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 13.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '13'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 13's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 13 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 14 Fedora Update System 2011-06-04 03:02:38 UTC
telepathy-sunshine-0.2.0-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-06-08 23:57:46 UTC
telepathy-sunshine-0.2.0-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2011-06-09 00:02:02 UTC
telepathy-sunshine-0.2.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.