Bug 633108 - Cannot connect to any database - makes DBD:Pg unusable.
Summary: Cannot connect to any database - makes DBD:Pg unusable.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-DBD-Pg
Version: 14
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Petr Šabata
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-13 00:23 UTC by Yves Dorfsman
Modified: 2010-10-08 12:37 UTC (History)
3 users (show)

Fixed In Version: perl-DBD-Pg-2.17.1-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-08 12:37:26 UTC


Attachments (Terms of Use)

Description Yves Dorfsman 2010-09-13 00:23:19 UTC
Description of problem:
Fails with an error when trying to connect to a postgres database with DBD::Pg.


Version-Release number of selected component (if applicable):
perl-DBD-Pg-2.17.1-2.fc14.i686
perl-5.12.2-133.fc14.i686
postgresql-8.4.4-3.fc14.i686
postgresql-server-8.4.4-3.fc14.i686
postgresql-libs-8.4.4-3.fc14.i686


How reproducible:
Very.


Steps to Reproduce:
Run the following script:

    #!/usr/bin/perl -w
    use DBI;
    my $dbh = DBI->connect("dbi:Pg:dbname=postgres", '', '', { AutoCommit => 0 } );

  
Actual results:
install_driver(Pg) failed: DBD::Pg object version 0 does not match bootstrap parameter 2.17.1 at /usr/lib/perl5/DynaLoader.pm line 223.
Compilation failed in require at (eval 3) line 3.


Expected results:
The script should just terminate with return code 0.

Comment 1 Marcela Mašláňová 2010-09-24 10:35:44 UTC
I can't reproduce this behaviour. Did you try full update? It looks like something is missing.

Comment 2 Yves Dorfsman 2010-09-24 14:04:59 UTC
full update?
What can I do beyond "yum update" and "yum upgrade" ?

I just removed anything perl, "yum remove perl*", and re-installing perl-DBD-Pg:

================================================================================
 Package                   Arch       Version                  Repository  Size
================================================================================
Installing:
 perl-DBD-Pg               i686       2.17.1-2.fc14            fedora     192 k
Installing for dependencies:
 perl                      i686       4:5.12.2-133.fc14        fedora      11 M
 perl-DBI                  i686       1.613-1.fc14             fedora     775 k
 perl-Module-Pluggable     noarch     1:3.90-133.fc14          fedora      37 k
 perl-Pod-Escapes          noarch     1:1.04-133.fc14          fedora      30 k
 perl-Pod-Simple           noarch     1:3.13-133.fc14          fedora     210 k
 perl-libs                 i686       4:5.12.2-133.fc14        fedora     611 k
 perl-version              noarch     3:0.82-133.fc14          fedora      50 k

Transaction Summary
================================================================================

And I still get the same error message.



Marcela: Do you mind posting your result of:
rpm -qa perl-DBI perl-DBD-Pg

Thanks.

Comment 3 Marcela Mašláňová 2010-09-24 14:17:14 UTC
I'm sorry, I don't use postgresql server, so I've noticed just now that I have to run this script as a postgresql user. Now I have the same error as you. No report on upstream yet, I'll check what's missing.

Comment 4 Fedora Update System 2010-09-30 12:49:20 UTC
perl-DBD-Pg-2.17.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/perl-DBD-Pg-2.17.1-3.fc14

Comment 5 Petr Šabata 2010-09-30 12:52:41 UTC
Yves,

please, test the proposed update. It should fix the reported issue.

Comment 6 Yves Dorfsman 2010-09-30 13:00:45 UTC
It does fix the problem indeed.

Thanks!

Comment 7 Fedora Update System 2010-09-30 21:18:29 UTC
perl-DBD-Pg-2.17.1-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update perl-DBD-Pg'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/perl-DBD-Pg-2.17.1-3.fc14

Comment 8 Fedora Update System 2010-10-08 12:37:21 UTC
perl-DBD-Pg-2.17.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.