Bug 633121 - /dev/dri is inaccessible
/dev/dri is inaccessible
Status: CLOSED DUPLICATE of bug 626559
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-12 22:10 EDT by Sean Middleditch
Modified: 2010-09-13 03:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-13 03:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Middleditch 2010-09-12 22:10:28 EDT
I can only get software rendering, used to get hardware rendering in Fedora 13.  HD4770 (rv740).  No idea if udev is responsible or not, maybe it's PAM or ConsoleKit or who knows what; the explosion in complexity of the Linux init system in the last few years, with its umpteen different daemons and packages doing tons of overlapping work, with their menagerie of wildly different home-grown config file formats, and not a single top-down document explaining the whole mess has made it close to impossible for me to figure out who does what when and where during boot-up.  So if you need more information, please just ask, because I have no clue what else might be relevant.

$ LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
libGL: OpenDriver: trying /usr/lib64/dri/r600_dri.so
libGL error: failed to open drm device: Permission denied
libGL: OpenDriver: trying /usr/lib64/dri/swrast_dri.so

$ ls -ld /dev/dri
drwxr-x--- 2 root root 80 Sep  3 00:18 /dev/dri/

$ rpm -q udev systemd kernel mesa-dri-drivers pam ConsoleKit
udev-161-2.fc15.x86_64
systemd-9-3.fc15.x86_64
kernel-2.6.36-0.14.rc3.git0.fc15.x86_64
mesa-dri-drivers-7.9-0.7.fc15.x86_64
pam-1.1.1-5.fc14.x86_64
ConsoleKit-0.4.2-1.fc14.x86_64
Comment 1 Sean Middleditch 2010-09-12 22:13:24 EDT
And just to confirm, if I chmod the access to /dev/dri and /dev/dri/card0 to give my user access, glxinfo reports the correct output and I get hardware accelerated rendering as I'd expect.

only after chmod'ing /dev/dri and /dev/dri/card0:
OpenGL renderer string: Mesa DRI R600 (RV740 94B3) 20090101  TCL DRI2
OpenGL version string: 2.1 Mesa 7.9-devel
Comment 2 Yanko Kaneti 2010-09-13 03:20:22 EDT

*** This bug has been marked as a duplicate of bug 626559 ***

Note You need to log in before you can comment on or make changes to this bug.