Bug 63321 - Cluadmin's nfs export checks fail for numeric options
Cluadmin's nfs export checks fail for numeric options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
2.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Jason Baron
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-12 11:50 EDT by Tim Burke
Modified: 2013-03-06 00:55 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-06 09:38:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Burke 2002-04-12 11:50:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Tim Burke wrote:
When you create an NFS service, it prompts for export options.  For example,
these may be rw,root_squash.  There are checks in the routines called by
cluadmin to validate that the export options are vaild.  This is relatively
simple for cases like "rw" and "root_squash".  There are other export options
which allow you to designate numeric values.  For example:
anonuid=-2,anongid=-2

Test case: verify that you can designate numeric export options during service
creation. Note: currently cluadmin emits a warning on this type, which it shouldn't.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Specify one of those numeric parameters and cluadmin will complain.
2.This problem only causes an annoying message, fortunately you can continue to
enter the desired parameter.
3.
	

Actual Results:  Warning messages appear.

Additional info:
Comment 1 Lon Hohberger 2002-06-18 14:22:37 EDT
This was due to two problems:
(1) cluadmin.tcl squeezed the whitespace out of mount/export options _after_ it
checked them in svc_db.c, and
(2) svc_db.c had two slight problems - the checks for the numeric args in
question ("anonuid", "anongid") didn't exist and the check function itself had a
bug when parsing numeric arguments.

Fixes in pool.

Note You need to log in before you can comment on or make changes to this bug.