This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 633212 - pathmunge error when logging in
pathmunge error when logging in
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: krb5 (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
: 639063 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-13 04:52 EDT by Jeremy Sanders
Modified: 2010-09-30 19:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: krb5-1.7.1-14.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-23 09:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Sanders 2010-09-13 04:52:09 EDT
Description of problem:
After yum has updated to the latest krb5, I now get errors when logging in:
-bash: pathmunge: command not found
-bash: pathmunge: command not found
-bash: pathmunge: command not found
-bash: pathmunge: command not found

If I move the krb5*.sh files somewhere else and log in, these errors go away.

My shell is bash.

Version-Release number of selected component (if applicable):
krb5-libs-1.7.1-13.fc12.i686
krb5-workstation-1.7.1-13.fc12.x86_64
krb5-devel-1.7.1-13.fc12.x86_64

How reproducible:
Every time
Comment 1 Jason Tibbitts 2010-09-13 09:38:09 EDT
I see this as well, with zsh, also on F12.
Comment 2 Nalin Dahyabhai 2010-09-13 10:45:55 EDT
Yikes, that's surprising.  From what I read in bug #544652, this was supposed to be a faster way to add things to the $PATH.  Which version of 'setup' do you have installed?  If you've made local customizations, is it possible that the default /etc/profile isn't there?
Comment 3 Jason Tibbitts 2010-09-13 10:59:01 EDT
I have setup-2.8.9-3.fc12.noarch which is current for F12.

/etc/profile is there and unchanged from the packaged version.  It does contain a definition of the pathmunge function (which is unset at the end of the script).
Comment 4 Nalin Dahyabhai 2010-09-13 11:07:20 EDT
It should be alright that it's unset at the end, since the profile.d scriptlet gets run before that, but it's not worth it to me to sort it out just now (particularly as the comments in #544652 suggest that there is a problem on upgrades), so I'm just going to undo this change.
Comment 5 Jeremy Sanders 2010-09-13 11:12:01 EDT
Ah, we have a customized /etc/profile. It looks like a new one with pathmunge was installed as /etc/profile.rpmnew, but of course didn't override the customization.

I'm not sure whether pathmunge was in the original F12 /etc/profile when the systems were installed.

So, either it is our fault and we used an ancient /etc/profile, or pathmunge was added to /etc/profile during F12 and we didn't spot it.
Comment 6 Nalin Dahyabhai 2010-09-13 11:18:58 EDT
(In reply to comment #3)
> I have setup-2.8.9-3.fc12.noarch which is current for F12.
> 
> /etc/profile is there and unchanged from the packaged version.  It does contain
> a definition of the pathmunge function (which is unset at the end of the
> script).

Aagh, can't resist: you mentioned you're using zsh, so you'd want to check on the zshrc file.

(In reply to comment #5)
> Ah, we have a customized /etc/profile. It looks like a new one with pathmunge
> was installed as /etc/profile.rpmnew, but of course didn't override the
> customization.
> 
> I'm not sure whether pathmunge was in the original F12 /etc/profile when the
> systems were installed.
> 
> So, either it is our fault and we used an ancient /etc/profile, or pathmunge
> was added to /etc/profile during F12 and we didn't spot it.

At least that explains it, thanks!
Comment 7 Fedora Update System 2010-09-13 11:21:02 EDT
krb5-1.7.1-14.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/krb5-1.7.1-14.fc13
Comment 8 Fedora Update System 2010-09-13 11:21:07 EDT
krb5-appl-1.0.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/krb5-appl-1.0.1-3.fc14
Comment 9 Fedora Update System 2010-09-13 11:21:13 EDT
krb5-1.7.1-14.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/krb5-1.7.1-14.fc12
Comment 10 Jason Tibbitts 2010-09-13 11:36:51 EDT
Oh, of course zsh doesn't source /etc/profile.  /etc/zshrc does have a function for sourcing the /etc/profile.d/*.sh files, but it does not define a pathmunge function.
Comment 11 Jason Tibbitts 2010-09-13 11:59:18 EDT
The issue with zsh is that the F13 package has the new pathmunge stuff, but since there is little reason to update the F12 package just for this, it does not have pathmunge.
Comment 12 Nalin Dahyabhai 2010-09-13 12:55:06 EDT
Oh, that's just disappointing.  The new candidate updates revert this change.  Sorry for the breakage.
Comment 13 Fedora Update System 2010-09-13 14:11:17 EDT
krb5-appl-1.0.1-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update krb5-appl'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/krb5-appl-1.0.1-3.fc14
Comment 14 Fedora Update System 2010-09-23 09:02:25 EDT
krb5-appl-1.0.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-09-24 16:47:06 EDT
krb5-1.7.1-14.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2010-09-30 06:29:33 EDT
krb5-1.7.1-14.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Elliott Forney 2010-09-30 19:08:16 EDT
*** Bug 639063 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.