This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 633234 - Previous grub entry is not overwritten after upgrade with creating new bootloader
Previous grub entry is not overwritten after upgrade with creating new bootlo...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-09-13 06:44 EDT by He Rui
Modified: 2010-10-06 18:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-14.17.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 00:08:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Grub.conf (13.66 KB, image/png)
2010-09-13 06:55 EDT, He Rui
no flags Details

  None (edit)
Description He Rui 2010-09-13 06:44:08 EDT
Description of problem:
Tested F14-beta-tc1 with  
http://fedoraproject.org/wiki/QA:Testcase_Anaconda_Upgrade_New_Bootloader
After upgrade, it still booted to F13 system which had already been replaced. In grub.conf, it just added F14 entry and the default one was still F13. 

Version-Release number of selected component (if applicable):
anaconda 14.17.1
F14-beta-tc1

How reproducible:
100%

Steps to Reproduce:
1. http://fedoraproject.org/wiki/QA:Testcase_Anaconda_Upgrade_New_Bootloader
2. Reboot
  
Expected results:
The previous grub entry(F13) should be replaced by the upgraded one(F14) in grub.conf.
Comment 1 He Rui 2010-09-13 06:46:51 EDT
Consider it's a beta blocker since:

10. The installer must be able to successfully complete an upgrade installation from a clean, fully updated default installation of the previous stable Fedora release, either via preupgrade or by booting to the installer manually
Comment 2 He Rui 2010-09-13 06:55:30 EDT
Created attachment 446888 [details]
Grub.conf

If it is by design that both entries should be in grub.conf, then the upgraded one should be on the top or booted by default
Comment 3 Adam Williamson 2010-09-14 15:48:10 EDT
Discussed at today's interim blocker review meeting. We agreed that this is a blocker. anaconda team is treating it as a high priority for investigation / fix.
Comment 4 Brian Lane 2010-09-15 13:17:08 EDT
I'm testing a fix for this now. I want to make sure it doesn't have side-effects so it may take a while. 

Even if this doesn't get fixed I don't think it should block -- the new grub.conf is written, it just doesn't put the new kernel at the top of the list. 

You can work around it by selecting the correct kernel manually from the GRUB menu.
Comment 5 Brian Lane 2010-09-15 17:25:45 EDT
Fixed in commit 861c91d5089b244e0d8831dea3547b664d18b2d3
Comment 6 Fedora Update System 2010-09-15 21:10:24 EDT
anaconda-14.17.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.2-1.fc14
Comment 7 Fedora Update System 2010-09-15 23:28:44 EDT
anaconda-14.17.2-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.17.2-1.fc14
Comment 8 Fedora Update System 2010-09-17 16:03:47 EDT
anaconda-14.17.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.3-1.fc14
Comment 9 Adam Williamson 2010-09-18 04:57:25 EDT
RC1 is now out and should include a fix for this:

http://serverbeach1.fedoraproject.org/pub/alt/stage/14-Beta.RC1/Fedora/

Please test and confirm this. Thanks!
Comment 10 Fedora Update System 2010-09-20 19:32:00 EDT
anaconda-14.17.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.4-1.fc14
Comment 11 Fedora Update System 2010-09-22 00:07:25 EDT
anaconda-14.17.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-10-06 18:02:53 EDT
anaconda-14.18-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.18-1.fc14

Note You need to log in before you can comment on or make changes to this bug.