Bug 63326 - redhat-config-squid.pot contains non-ascii words/characters
redhat-config-squid.pot contains non-ascii words/characters
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: squid-config (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-12 12:13 EDT by Christian Rose
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-14 22:50:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2002-04-12 12:13:51 EDT
#: redhat-config-squid.gladestrings:342
msgid "\316\273\262\362"
msgstr ""

#: redhat-config-squid.gladestrings:339
msgid "\274\350\276\303"

This seems to be an octal hack(?) to get some fancy characters. This is broken
because msgid:s in a pot file should only contain ASCII (as an exception, if all
translations use UTF-8, the msgid can also contain UTF-8 characters).

This is because there can't be multiple encodings in the same po file, so any
fancy characters that are included in the msgids will be interpreted as
something encoded in the encoding of the rest of the po file, which may be
something entirely different than the original string, so lookups of this string
will almost always fail unless the translation happens to use the same character
set.
Comment 1 Bill Huang 2002-04-14 22:50:48 EDT
It is fixed in CVS on i18n.redhat.com.

Note You need to log in before you can comment on or make changes to this bug.