Bug 63329 - The is keymap is slightly wrong
The is keymap is slightly wrong
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-12 13:07 EDT by Richard Allen
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-30 03:29:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Allen 2002-04-12 13:07:26 EDT
Description of Problem: 
The is keymap (/usr/X11R6/lib/X11/xkb/symbols/is) is not 
100% correct. Most noticable is the fact that the "`" key is 
missing. Rather annoying for us who do any scripting at all. 
 
Version-Release number of selected component (if applicable): 
It's been like this for quite some time. We here in Iceland 
have adapted to it and this version of the is keymap has been 
publicly available since the 6.2 release.   And it just hit 
me, why not try to get you guys to include it in the new 
upcoming release :) 
 
How Reproducible: 
Every time 
 
Steps to Reproduce: 
1. load the is keymap 
2. press the ` key 
3.  
 
Actual Results: 
Something else appears ;) 
 
Expected Results: 
the ` should appear 
 
Additional Information: 
Here is the chance to win the gratitude of people who script 
in Iceland ;)
Comment 1 Richard Allen 2002-04-12 13:27:55 EDT
Cant attach the keymap. youll find it at http://www.ra.is/is
Comment 2 Mike A. Harris 2002-04-13 06:40:18 EDT
The best thing to do, is to submit fixes like this directly to XFree86.org
as soon as a bug is known, and a fix available.  That way, once they put
the fix in place, it can get a lot of testing, and will make it automatically
into all distributions.

It is a difficult chore for distribution maintainers to maintain a large
number of keymap files that differ from the stock releases, and have to
resync the customizations with each new XFree86 release.

I'm marking this as DEFERRED for future release for now, however if
someone will attach a unified diff (diff -u) of the keymap file from
the XFree86 source code (not the one installed on the system), containing
the needed changes, and reopen the report, I will try to add the patch to
a future release until it is in the upstream sources.

Again, it is always best to file these sort of reports directly with
XFree86.org.  Bug reports can be sent to xfree86@xfree86.org, and patches
and fixes can be sent to fixes@xfree86.org


Note You need to log in before you can comment on or make changes to this bug.