Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 63332 - ucd-snmp-4.2.4.pre3-4 agent times out with view restrictions
ucd-snmp-4.2.4.pre3-4 agent times out with view restrictions
Status: CLOSED DUPLICATE of bug 23034
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-12 13:32 EDT by Darren Gamble
Modified: 2015-03-04 20:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-30 15:19:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Gamble 2002-04-12 13:32:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
The 4.2.4.pre3-4 agent doesn't appear to handle view restrictions.  If a client 
with such restrictions tries to query the server (depending on which subtrees 
it has access to) either incomplete information is returned before the request 
times out, or no information is returned at all.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Using the "view" config option, restrict a client to only the "system" 
and ".1.3.6.1.4.1.2021.11" (systemStats) tables.
2. Restart the agent.
3. Query the agent from a host that is restricted via this view.

	

Actual Results:  The "system" table is returned, and then the connection times 
out.

Expected Results:  The "system" and "systemStats" tables should have been 
returned.

Additional info:

After doing this, the agent uses all of the CPU, preventing any further queries 
from any host.  It appears to return to normal after 10-15 seconds.

This was working properly with the 4.2.3 agent.  Normally we would be using 
that version, but diskspace support is wholely broken in the Redhat RPM for 
4.2.3 ...
Comment 1 Darren Gamble 2002-04-12 13:37:16 EDT
I should add that the queries were done via "snmpwalk".
Comment 2 Christian Hechelmann 2002-04-30 15:19:46 EDT
I seem to remember that there was similar behaviour in the past.  
during the time the agent consumes all CPU, it is actually walking the mib 
internaly (you can see this clearly when you anable debug output). 
Comment 3 Phil Knirsch 2002-06-25 12:09:16 EDT
Exactly.

And as it needs to do quite a bit of work on loaded machines it takes quite some
time to do so.

So either increase the timeout value of your snmpwalk command or explicitly
query the OID's you are interessted in.

This bug has already been reported a couple of times btw.

Read ya, Phil

*** This bug has been marked as a duplicate of 23034 ***

Note You need to log in before you can comment on or make changes to this bug.