This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 633332 - [6.1 FEAT] performance enhancements to libcmpiutil
[6.1 FEAT] performance enhancements to libcmpiutil
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libcmpiutil (Show other bugs)
6.1
x86_64 All
medium Severity medium
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
: FutureFeature, OtherQA, Rebase
Depends On:
Blocks: 538808 669731 693823
  Show dependency treegraph
 
Reported: 2010-09-13 11:23 EDT by IBM Bug Proxy
Modified: 2011-05-19 09:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: libcmpiutil-0.5.4-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The libcmpiutil package has been upgraded to upstream version 8.5.4, which improves performance and is a prerequisite for the new interfaces provided by the libvirt-cim package update as the package depends on the libcmpiutil library.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:49:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Key changes since 0.5.1 (5.08 KB, text/plain)
2010-11-30 14:21 EST, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67256 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-13 11:23:41 EDT
1. Feature Overview:
Feature Id: [67256]
a. Name of Feature: [6.1 FEAT] performance enhancements to libcmpiutil
b. Feature Description
incorporate a number of performance enhancements discovered when testing current versions of libcmpiutil

2. Feature Details:
Sponsor: LTC Open Virtualization
Architectures:  x86_64, 

Arch Specificity: purely common code
Affects Kernel Modules: Field does not exist
Delivery Mechanism: Direct from Community
Category: system management
Request Type: Package - Update Version
d. Upstream Acceptance: Field does not exist
Sponsor Priority P3
f. Severity: normal
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target:---

3. Business Case
Increases efficiency of IBM Systems Director which reduces overhead of managing VMs.

4. Primary contact at Red Hat:
John Jarvis jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael W. Wortman, wortman@us.ibm.com

Technical contact(s):
Harold E. Vincent, cvincent@us.ibm.com
Comment 3 John Jarvis 2010-11-23 15:33:27 EST
IBM is signed up to test and provide feedback, setting OtherQA.
Comment 4 IBM Bug Proxy 2010-11-30 14:21:01 EST
Created attachment 463807 [details]
Key changes since 0.5.1


------- Comment on attachment From cvincent@linux.vnet.ibm.com 2010-11-30 14:13 EDT-------


For reference, here are changesets from the current upstream version (
changeset:   99:f967d9432f31
tag:         tip
user:        Sharad Mishra <snmishra@us.ibm.com>
date:        Wed Oct 06 09:31:05 2010 -0700
summary:     Missing namespace from migration indications

changeset:   97:d4beac1f62c6
tag:         release_0_5_3
user:        Chip Vincent <cvincent@us.ibm.com>
date:        Tue Sep 14 21:19:05 2010 -0400
summary:     Change owner and rev version to 0.5.3   <- ommitted version change

changeset:   96:8715fb1b3e6c
user:        Sharad Mishra <snmishra@us.ibm.com>
date:        Fri Aug 27 13:57:50 2010 -0400
summary:     Adding CMReturnDone after CMPI InvokeMethod
Comment 5 IBM Bug Proxy 2010-12-01 00:10:46 EST
------- Comment From cvincent@linux.vnet.ibm.com 2010-12-01 00:01 EDT-------
*** Bug 67232 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Veillard 2011-01-11 02:13:26 EST
what about the 3 recent patches pushed :

99:f967d9432f31 
100:531f151df659 
and
101:6559c111bc9b 

?

Since I will build the package soon, probably better to get in the last patches

Daniel
Comment 7 John Jarvis 2011-01-12 13:35:32 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 9 Daniel Veillard 2011-01-17 02:48:23 EST
The package is being rebased to latest version plus one missing patch,
it includes the above set of patches,

Daniel
Comment 13 Cui Chun 2011-03-21 03:08:12 EDT
Changed it to verified status according to comment 12.
Comment 14 Eva Kopalova 2011-04-15 08:55:39 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The libcmpiutil package has been upgraded to upstream version 8.5.4, which improves performance and is a prerequisite for the new interfaces provided by the libvirt-cim package update as the package depends on the libcmpiutil library.
Comment 15 errata-xmlrpc 2011-05-19 09:49:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0641.html

Note You need to log in before you can comment on or make changes to this bug.