Bug 633355 - [6.1 FEAT] Enhance cio_ignore usage in scripts using new handler for pending work - post.config tools part
[6.1 FEAT] Enhance cio_ignore usage in scripts using new handler for pending ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-services (Show other bugs)
6.1
s390x All
high Severity high
: beta
: 6.1
Assigned To: Nils Philippsen
qe-baseos-daemons
: FutureFeature
Depends On:
Blocks: 633862 538808 580566
  Show dependency treegraph
 
Reported: 2010-09-13 12:11 EDT by IBM Bug Proxy
Modified: 2010-11-30 05:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 10:41:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67037 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-13 12:11:49 EDT
1. Feature Overview:
Feature Id: [67037]
a. Name of Feature: [6.1 FEAT] Enhance cio_ignore usage in scripts using new handler for pending
work - post.config tools part
b. Feature Description
This feature requests to enhance the cio_ignore usage in post-configuration tools by taking
advanctage of the new cio_ignore handler to wait for cio pending work.


2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:
  zSeries - 64 native, 

Arch Specificity: purely arch specific code
Affects Kernel Modules: Field does not exist
Delivery Mechanism: LDP Deliverable
Category: other
Request Type: Code Development Support from Distributor
d. Upstream Acceptance: Field does not exist
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: 3rd party code
g. Component Version Target:
---

3. Business Case
This feature will avoid running into possible race condition, making the code more stable. 
Resulting on less service cost and better customer satisfaction.

4. Primary contact at Red Hat:
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 3 IBM Bug Proxy 2010-10-04 12:35:36 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 10:42 EDT-------
Code Upstream Status: No Code Required
Comment 4 John Jarvis 2010-10-04 14:12:37 EDT
IBM, can you please provide more details on what is being requested here?
Comment 5 Nils Philippsen 2010-11-10 10:41:38 EST
This doesn't seem to relate to system-config-services, closing.
Comment 6 IBM Bug Proxy 2010-11-30 05:11:49 EST
------- Comment From mgrf@de.ibm.com 2010-11-30 05:02 EDT-------
Close this feature request as duplicate
to   66875 - RHBZ 631527 -  [6.1 FEAT] Provide userspace handle to wait for cio
pending work - userspace

The functionality could be implemented into s390tools (s390utils) only and get referred to during install and boot.
The calls from installer and scripts already exist with RHEL6  (6.0 FEAT cio_ignore...)  feature request.
.
So nothing to implement for post config tools anymore.

*** This bug has been marked as a duplicate of bug 66875 ***

Note You need to log in before you can comment on or make changes to this bug.