Bug 633373 - Source completion is very slow
Summary: Source completion is very slow
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gtksourceview2
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-13 16:44 UTC by Sébastien Wilmet
Modified: 2010-10-09 20:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-09 20:06:42 UTC


Attachments (Terms of Use)
2000+ words beginning with "aa" (11.88 KB, application/octet-stream)
2010-09-13 16:44 UTC, Sébastien Wilmet
no flags Details

Description Sébastien Wilmet 2010-09-13 16:44:51 UTC
Created attachment 446993 [details]
2000+ words beginning with "aa"

Description of problem:
Source completion with gtksourceview is very slow. We can check this problem easily with the Word Completion plugin of Gedit, but I have the same problem with other applications that uses gtksourceview for auto-completion.

Version-Release number of selected component (if applicable):
gtksourceview2-2.11.2-3.fc14
gtk2-2.21.7-1.fc14

Steps to Reproduce:
1. install gedit-plugins
2. enable the Word Completion plugin in Gedit
3. open a file containing a lot of words (see attachment)
4. type the beginning of a word until proposals appear: the time to wait for proposals to appear is normal for the first time, maybe a bit slower tough
5. delete one character: it is very slow
6. retype the character: the proposals take several seconds to appear
  
Actual results:
Completion is very slow

Expected results:
The performances must be the same as with Fedora 13 (i.e. almost instantaneously)

Comment 1 Sébastien Wilmet 2010-09-13 16:56:17 UTC
I've downgraded to gtksourceview2-2.10.2-1.fc14 and the problem still happens.
So I don't know where this bug could come from, if it's not gtksourceview then it's maybe GTK...

Comment 2 Hicham HAOUARI 2010-09-28 17:22:34 UTC
It doesn't matter how much files nautilus is gonna display, sometimes it "hangs" with less than 10 items to display.

How can "catch" nautilus in gdb ?

Comment 3 Hicham HAOUARI 2010-09-28 17:24:06 UTC
sorry, wrong bug

Comment 4 Sébastien Wilmet 2010-10-09 20:06:42 UTC
The bug seems to be fixed for me.
I think this bug was related with bug 626108 (which was closed after the update to glib2-2.26.0-2).


Note You need to log in before you can comment on or make changes to this bug.