Bug 633414 - [6.1 FEAT] HBA API Completion - library part
[6.1 FEAT] HBA API Completion - library part
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
6.1
s390x All
high Severity high
: alpha
: 6.1
Assigned To: Dan Horák
qe-baseos-daemons
: FutureFeature, OtherQA
Depends On:
Blocks: 538808 633890 580566
  Show dependency treegraph
 
Reported: 2010-09-13 14:02 EDT by IBM Bug Proxy
Modified: 2011-05-19 09:17 EDT (History)
9 users (show)

See Also:
Fixed In Version: s390utils-1.8.2-29.el6
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 67054 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-09-13 14:02:45 EDT
1. Feature Overview:
Feature Id: [67054]
a. Name of Feature: [6.1 FEAT] HBA API Completion - library part
b. Feature Description
This feature extends the previous version of libzfcphbaapi (2.0). libzfcphbaapi is an implementation
of the standard HBA API (see t11.org) for the System z FCP host bus adapter. There have been two
major additions in the following areas:
??? FCP pass-through support: it is possible to construct CT (Common Transport for Generic Services,
see document "Fibre Channel Generic Services" available at t11.org) and ELS (Extended Link Services,
see document "Fibre Channel Link Services" available at t11.org) frames in the userspace and send
them into the SAN now. Please note that while it is possible to construct any CT frame, the ELS
requests are predefined. Currently the only supported ELS request is "Request Node Identification Data".
??? event support: events occuring in the SAN can be retrieved now.

This is the library part. There is a dependent kernel part which is tracked by different feature
request.


2. Feature Details:
Sponsor: LTC zSeries BOE
Architectures:  zSeries - 64 native, 

Arch Specificity: purely arch specific code
Affects Kernel Modules: Field does not exist
Delivery Mechanism: Backport
Category: system management
Request Type: Package - Feature from IBM
d. Upstream Acceptance: Field does not exist
Sponsor Priority P1
f. Severity: ship issue
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target:---

3. Business Case
This feature provides the infrastructure needed to improve the system management capabilities of FCP
devices.

4. Primary contact at Red Hat:
John Jarvis jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com
Comment 2 Gonzalo Muelas Serrano 2010-09-24 09:23:36 EDT
Hello John,
this will be part of HBA API library and be provided as a backport to existing
RHEL 6.0 version.
It is upstream with libzfcphbaapi 2.1
http://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi-2.1.html

Unfortunately through the mirroring this information got lost. I have updated
the component here directly.

I have created a tracker for zfcp hba api requests (kernel+library):
Bug 633890 - Feature Tracker - HBA API Completition
Comment 3 IBM Bug Proxy 2010-10-04 11:15:10 EDT
------- Comment From rsisk@us.ibm.com 2010-10-04 10:36 EDT-------
Code Upstream Status: Accepted
Comment 4 Hendrik Brueckner 2010-11-18 09:02:15 EST
Petr, Dan,

I think the libzfcphbaapi lib is a subpackage of the s390utils, so adding Dan to CC.  Dan, this feature bug is about upgrading the lib to version 2.1 which is available on the developerWorks website.

Thanks and regards,
Hendrik
Comment 5 Dan Horák 2010-11-18 09:36:22 EST
switching to s390utils that carry the vendor library
Comment 8 John Jarvis 2010-12-01 09:37:46 EST
This enhancement request was evaluated by the full Red Hat Enterprise Linux 
team for inclusion in a Red Hat Enterprise Linux minor release.   As a 
result of this evaluation, Red Hat has tentatively approved inclusion of 
this feature in the next Red Hat Enterprise Linux Update minor release.   
While it is a goal to include this enhancement in the next minor release 
of Red Hat Enterprise Linux, the enhancement is not yet committed for 
inclusion in the next minor release pending the next phase of actual 
code integration and successful Red Hat and partner testing.
Comment 9 IBM Bug Proxy 2010-12-08 09:51:28 EST
------- Comment From mgrf@de.ibm.com 2010-12-08 09:43 EDT-------
Just got confirmation per mail from John
- Red Hat approved to enhance the version of the library from 2.0 to 2.1

Since the only diff from libzfcphbaapi version 2.0 to 2.1 is the code for the R 6.1  feature request it is useless to backport that code
Comment 10 IBM Bug Proxy 2010-12-08 10:52:24 EST
------- Comment From mgrf@de.ibm.com 2010-12-08 10:41 EDT-------
Please down load libzfcphbaapi 2.1 from
http://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi.html
Comment 13 Chris Ward 2011-04-06 07:13:14 EDT
~~ Partners and Customers ~~

This bug was included in RHEL 6.1 Beta. Please confirm the status of this request as soon as possible.

If you're having problems accessing 6.1 bits, are delayed in your test execution or find in testing that the request was not addressed adequately, please let us know.

Thanks!
Comment 14 IBM Bug Proxy 2011-04-28 03:01:38 EDT
------- Comment From mgrf@de.ibm.com 2011-04-28 02:51 EDT-------
This feature is verified on R 6.1 snapshots - set to verified. Thx
Comment 15 errata-xmlrpc 2011-05-19 09:17:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0601.html

Note You need to log in before you can comment on or make changes to this bug.