Bug 63351 - mke2fs hangs on large RAID partition
mke2fs hangs on large RAID partition
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2002-04-12 17:25 EDT by Hrunting Johnson
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-04-12 17:25:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Hrunting Johnson 2002-04-12 17:25:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I have 10 72GB 10000RPM drives connected via fibrechannel using software RAID 
on an 8-CPU Dell 8450 box with 4GB of RAM and plenty of internal hard disk 
space (>18GB).  I setup 5 mirrors (sda1-sdf1, sdb1-sdg1, etc.), let their 
mirrors sync, then RAID0 them.  End result is one 350GB md device.  Then I run 
mke2fs on that 350GB device to create the filesystem.  Around inode 250 or so, 
it begins to slow down.  Around inode 430, it stops altogether.  The machine 
isn't locked up, and it reports no CPU usage, no I/O usage across the FC 
drives.  mke2fs is in an uninterruptible sleep state.  This is a fresh RH7.2 
install, no errata, no changes from a default installation.  No errors appear 
in dmesg or /var/log/messages.  mdstat reports no failures in the drives.  

I have another 8-CPU Compaq 8500, 4GB RAM, almost identical setup, with the 
same problem.  This box is also RedHat 7.2 with all current (as of today) 
errata in place.  I have the same problem with this machine, although this 
machine is in production on internal drives, so I can't test with it anymore.  
Furthermore, when I was testing with it, sometimes the freeze up would affect 
other I/O on the system, causing other programs to pause or hang.

Machine 1 has a QLA2200 FC card
Machine 2 has a QLA2300 FC card

Syncing of the drives in both cases worked just fine.  There were no pauses or 
hangups, so it's likely not a driver issue.  I debated putting this under 
kernel, because it smells of a kernel issue, but the direct problem is related 
right now to mke2fs.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Setup machine.
2.Setup mirrors.
3.Run mke2fs

Actual Results:  mke2fs stops

Expected Results:  mke2fs finishes

Additional info:
Comment 1 Florian La Roche 2002-08-02 04:22:03 EDT
This has todo with kernel VM problems and newer kernels should work better
with this.

Thanks a lot,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.