Bug 63367 - failure to boot after serial install when using grub as boot loader
failure to boot after serial install when using grub as boot loader
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
skipjack-beta2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-04-12 19:58 EDT by RLX Technologies
Modified: 2007-03-26 23:52 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 01:51:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RLX Technologies 2002-04-12 19:58:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020326

Description of problem:
A system using only a serial console fails to boot after install when using grub
as the boot loader.  This issue is present in 7.2.93 (Skipjack).

How reproducible:
Always

Steps to Reproduce:
1. Perform install from the serial console
2. Choose grub as boot loader

Actual Results:  I believe that grub is loading, but since it is not configured
during install to output to the serial console (like lilo) I get no output.  The
problem causing it not to boot is that it is waiting for input and grub will
never time out.  Also the xpm splash file may be causing problems with the
serial port.

Expected Results:  Grub should be configure to output to the serial console.
Comment 1 Jeremy Katz 2002-04-15 16:47:59 EDT
It should timeout since we're setting the timeout to 10 in the grub config and
seems to work for me.  Are you sure it's not hanging anywhere else in boot?

(setting up grub to use the serial console wasn't done in 7.2 either, and we're
past the point of feature changes)
Comment 2 RLX Technologies 2002-04-15 17:41:11 EDT
The generated "timeout=10" doesn't work for us at all.  One or more things are
wrong.  The grub info doc says to use "timeout 10" - notice no equal sign. 
However, I think that this will still - NOT - work for a serial console.  To get
a serial console to work I had to use something like the following (ttyS0):

default 0
timeout 10
serial --unit=0 --speed=38400
terminal --timeout=10 serial

Notice that there are two different timeout values.  One "timeout" and another 
"--timeout=nn" associated with the terminal line.  Without the "--timeout=nn"
being set, and no serial console connected, it would never boot for us since the
code has a "-1", or something less than 0, in the "to" (timeout) field.
Comment 3 Jeremy Katz 2002-04-15 18:31:56 EDT
This is not a regression from 7.2 and requires a few more changes than I'd like
to make this late to get "right"  (I need to be able to determine where your
serial console is as well as what the settings are for baud and parity). 
Deferring to do properly for the next release.
Comment 4 Jeremy Katz 2002-07-18 01:51:50 EDT
Fixed in CVS
Comment 5 Jay Turner 2002-09-04 09:18:15 EDT
Fix confirmed with re0903.2 tree.
Comment 6 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.