Bug 633693 - KVM guest will have a long time drift after migrating repeatly.
KVM guest will have a long time drift after migrating repeatly.
Status: CLOSED DUPLICATE of bug 655990
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Glauber Costa
Virtualization Bugs
: Triaged
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-09-14 05:10 EDT by YangGuang
Modified: 2011-01-18 05:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-18 05:04:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description YangGuang 2010-09-14 05:10:12 EDT
Description of problem:
I use Rhev-manager (sm81) to create a kvm guest. Before migrating, synchronize the guest time with ntp server. Then executing 10 times migrations repeatly. After these operations, check and compare the guest time with ntp server. Then we find that there is 85 seconds time drift in guest and no time drift in host. 


Version-Release number of selected component (if applicable):
Rhev-manager (sm81)

host: Rhev-hypervisor-5.5-2.2.6.1
kernel-2.6.18-194.11.1.el5
kvm-83-164.el5_5.21

guest: RHel 5.5 x86_64 
kernel-2.6.18-214.el5


How reproducible:
always

Steps to Reproduce:
1.Before shut down kvm guest, do time synchronization with ntp server.

[guest]# ntpdate 10.5.26.10
14 Sep 04:51:28 ntpdate[2375]: adjust time server 10.5.26.10 offset 0.000240 sec

2. Migrate kvm guest 10 times repeatly.
3. After migrations, check the guest time with ntp server.
 
[guest]# ntpdate -q 10.5.26.10
server 10.5.26.10, stratum 1, offset -85.304423, delay 0.39574
14 Sep 05:03:45 ntpdate[2706]: step time server 10.5.26.10 offset -85.304423 sec

Actual results:
1. After step 3, it occurs about 85 seconds time drift. 

Expected results:
1.  After step 3, it should not occur time drift. 

Additional info:
The qemu command line used in rhev-hypervisor-5.5-2.2.6.1:
vdsm     10933  0.0  0.0   8668  1088 ?        S<s  09:01   0:00 /bin/sh -c /usr/bin/sudo /usr/bin/tunctl -d virtio_10_1; /usr/bin/sudo /usr/bin/tunctl -b -u vdsm -t virtio_10_1;/usr/bin/sudo /sbin/ip link set dev virtio_10_1 address fe:1a:4a:42:41:81;/usr/bin/sudo /sbin/ip link set dev virtio_10_1 up;/usr/bin/sudo /usr/sbin/brctl addif rhevm virtio_10_1;TZ=UTC /bin/nice -n 5 /usr/libexec/qemu-kvm -no-hpet -usbdevice tablet  -rtc-td-hack  -startdate 2010-09-14T17:01:17  -name test-rhel5-5-x  -smp 1,cores=1  -k en-us  -m 512  -boot c  -net nic,vlan=1,macaddr=00:1a:4a:42:41:81,model=virtio -net tap,vlan=1,ifname=virtio_10_1,script=no  -drive file=/rhev/data-center/ca69b608-e64a-49f6-baa9-19eadaf339d8/08e9a1bd-e22a-45da-b9a2-4f2037e81b9b/images/203cf59b-b0dc-41fe-aa17-46385dfc8f70/d0368ee1-d538-45bd-b0bb-24dc1a00a46b,media=disk,if=virtio,cache=off,serial=fe-aa17-46385dfc8f70,boot=on,format=raw,werror=stop -pidfile /var/vdsm/b2a90dd4-2172-4329-a4c5-86ac524b64a4.pid -vnc 0:10,password  -incoming tcp::49180 -cpu qemu64,+sse2,+cx16,+ssse3  -M rhel5.5.0  -notify all  -balloon none  -smbios type=1,manufacturer="Red Hat",product="RHEV Hypervisor",version=5.5-2.2-6.1,serial="44454C4C-4D00-1036-8048-B4C04F4D3258_00:22:19:b4:2c:a9",uuid="b2a90dd4-2172-4329-a4c5-86ac524b64a4"  -vmchannel di:0200,unix:/var/vdsm/b2a90dd4-2172-4329-a4c5-86ac524b64a4.guest.socket,server -monitor unix:/var/vdsm/b2a90dd4-2172-4329-a4c5-86ac524b64a4.monitor.socket,server 1>/var/vdsm/b2a90dd4-2172-4329-a4c5-86ac524b64a4.stdio.dump 2>&1; /usr/bin/sudo /usr/bin/tunctl -d virtio_10_1;
Comment 2 Glauber Costa 2011-01-18 05:04:53 EST
This sound like a duplicate of a regression we recently came across.

I am closing it as as such, but please reopen if you still see this problem
with the most recent bits from the hypervisor. (kvm >= 83-219)

*** This bug has been marked as a duplicate of bug 655990 ***

Note You need to log in before you can comment on or make changes to this bug.