Bug 63377 - Installer hangs when loading yenta socket
Installer hangs when loading yenta socket
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2002-04-12 23:59 EDT by George Milner
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description George Milner 2002-04-12 23:59:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
Doing a NFS install on a Panasonic CF-27 laptop.
Lapop install hangs right after inserting the pcmciadd.img disk.  The last
message I can get is loading the yenta driver.  I have tried two different 3com
pcmcia cards on the same laptop.  The 3CCE589EC pcmcia card works fine.  The
3CXFE575BT card fails.  I've verified the 3CXFE575BT card is functional by using
it to do a RedHat 6.2 install on the same laptop.  Sorry, the hang keeps me from
getting more information.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot using pcmcia.img and a 3CXFE575BT 10/100 pcmcia adapter.
2. When System asks for pcmciadd.img disk.  Insert It and hit return.
3. System hangs.

Additional info:
Comment 1 Jeremy Katz 2002-04-14 01:48:57 EDT
If you install using the 3CXFE575BT, does the 3CCE589EC work after installing?
Comment 2 George Milner 2002-05-02 19:23:30 EDT
Sorry for the slow reply.  I don't have regular access to the laptop.  I
"can-not" install skipjack-b2 using the 3CXFE575BT.  I installed RedHat 6.2
using the 3CXFE575BT just to verify the the card hardware was good.  After
loading skipjack using the 3CCE589EC, inserting the 3CXFE575BT hangs the system.
 I have not found anyway to get debugging information from the yenta_socket
driver to assist in finding the problem.  I tried disabling serial and usb
devices in the BIOS to free up resources and I tried the latest 2.4.19-pre7-ac3
kernel. No luck, and I'm losing  the laptop again.
Comment 3 Jeremy Katz 2002-05-09 16:41:01 EDT
Sounds like a kernel problem, but without more concrete information on working
with current kernels, there's probably not much Arjan can do.
Comment 4 Scott Russell 2002-08-12 17:57:06 EDT
Using kernel UNI i686 .95 kernel from rawhide on the limbo public beta I'm
seeing yenta socket hangs during boot. If I remove pcmcia from the init.d start
up I can boot and then issue:

/sbin/service pcmcia start
Ctrl-C to kill the hang
/sbin/service pcmcia stop
/sbing/service pcmcia start

to get my pcmcia working. I had no troubles with hangs during install.
Comment 5 Bugzilla owner 2004-09-30 11:39:30 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.