Bug 63403 - Delete key not working in vi/less under xterm
Delete key not working in vi/less under xterm
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: vim (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 08:25 EDT by Jukka Lehti
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-16 12:43:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jukka Lehti 2002-04-13 08:25:18 EDT
Description of Problem:

I have added following lines to ~/.Xresources to enable the Delete and other
keys to work as I prefer in xterm (Delete removes a char before the cursor
position):

  xterm*VT100.Translations: #override\n\
        <KeyPress>Prior:        scroll-back(1,page)\n\
        <KeyPress>Next:         scroll-forw(1,page)\n\
        <KeyPress>Home:         string(0x01)\n\
        <KeyPress>End:          string(0x05)\n\
        <KeyPress>Delete:       string(0x04)\n\
        <KeyPress>BackSpace:    string(0x7F)

The keys defined above as work expected in every application but Delete
misbehaves in vi and less. In vi, pressing Delete does nothing, and in less
pressing delete when writing (e.g., search parameters) prints ^D. Removing
Delete definition from ~/.Xresources is not an options since it break other
applications.


Version-Release number of selected component (if applicable):

less-358-24
vim-common-6.1-2

How Reproducible:

Always.

Steps to Reproduce:
1. Add lines from above to ~/.Xresources
2. start X
3. start xterm
4. run vi or less, type something and try to use Delete

Additional Information:
	
Same problem is with RH7.2+errata, there is also Backspace broken in vi/less
(produces ^?) but Backspace is working with skipjack. All other apps (emacs,
pico, etc) are ok.
Comment 1 Bernhard Rosenkraenzer 2002-04-15 12:02:47 EDT
What applications does removing nonstandard redefinitions of standard keys 
break? Those applications need fixing, vim/less are working correctly.
Comment 2 Jukka Lehti 2002-04-16 12:43:48 EDT
Hmm, after testing everything I can imagine: no apps broke! I added the
redefinitions during RH6.x era, so I guess they are no obsolete.

Please close this bug, and sorry for wasting everybody's time!

Note You need to log in before you can comment on or make changes to this bug.