Bug 634040 - gnome-volume-control-applet repeatedly crashes and does not control sound
Summary: gnome-volume-control-applet repeatedly crashes and does not control sound
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-15 02:17 UTC by Jon Masters
Modified: 2013-03-12 08:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-12 08:35:09 UTC
Type: ---


Attachments (Terms of Use)

Description Jon Masters 2010-09-15 02:17:36 UTC
Description of problem:

The latest gnome-volume-control-applet in rawhide crashes after clicking on it a couple of times, then right clicking (for example). When using it, it also does not correctly set the sound, though this might be pulseaudio at fault. The problem seems to occur in gtk_device_grab_remove when removing a GtkVScale widget (perhaps this is the horizonal slider?), then hits a busted pointer.

Version-Release number of selected component (if applicable):

gnome-media-2.31.5-5.fc15.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Login to desktop wherein a volume control widget is running
2. Click on he widget a couple of times, adjust the sound, right click, etc.
3. Crash. Results vary when being traced or at different times.
  
Actual results:

Widget crashes, cannot control sound.

Expected results:

Ability to set the sound to a desired output level. To turn the sound on, or to turn the sound off, like on other Operating Systems.

Additional info:

Comment 1 Jon Masters 2010-09-16 03:55:21 UTC
Full core dump of the crash (Buzilla limit reached so hosted externally):

http://www.jonmasters.org/tmp/rhbz634040/gnome-media_gnome-volume-control-applet_2.31.5-5.fc15.x86_64.core.bz2

Jon.

Comment 2 Jon Masters 2010-11-09 01:05:33 UTC
This is still not working, but now doesn't even launch. I have discovered in gdb that this app will now only launch if you start it with --debug due to a check on line 80 in the startup code. But even when you do start it, there is not icon now.

Comment 3 Jon Masters 2010-11-09 01:30:39 UTC
Starts fine with pulseaudio removed completely from the system. I wonder if this is a DBUS problem, since there was a DBUS error as part of the backtrace on startup. For now, I've just removed pulseaudio and filed a separate bug against gnome-bluetooth to make sure its dependency on pulse is also fixed.

Comment 4 Fedora Admin XMLRPC Client 2013-02-24 10:42:13 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Fedora Update System 2013-03-04 07:39:26 UTC
gnome-media-3.4.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-media-3.4.0-4.fc18

Comment 6 Fedora Update System 2013-03-04 07:40:25 UTC
gnome-media-3.4.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnome-media-3.4.0-4.fc17

Comment 7 Fedora Update System 2013-03-04 22:36:39 UTC
Package gnome-media-3.4.0-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-media-3.4.0-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3409/gnome-media-3.4.0-4.fc18
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-03-12 08:35:11 UTC
gnome-media-3.4.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-03-12 08:50:24 UTC
gnome-media-3.4.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.