Bug 634135 - enabling VT-d produces flooding of error messages on Lenovo T510
Summary: enabling VT-d produces flooding of error messages on Lenovo T510
Status: CLOSED DUPLICATE of bug 605888
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-15 10:34 UTC by Karel Volný
Modified: 2010-09-15 13:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-15 13:01:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karel Volný 2010-09-15 10:34:40 UTC
Description of problem:
after enabling VT-d in BIOS of my ThinkPad T510, my logs get flooded by error messages, leading to performance problems and my harddisk filing up (over 400 GB in just a few hours)

Version-Release number of selected component (if applicable):
kernel-2.6.34.6-54.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. enable VT-d in BIOS
2. boot
3. tail /var/log/messages
  
Actual results:
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault addr ff[fault reason 02] Present bit in context entry is clearext entry is clear
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fau Request device [0d:00. Request device [0d:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Present bit ifffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Present bit in context entry is clear
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Rearesent bit in context entry is clear
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMA<3>DMAR:[DMA Read] Request device [0d:00.0] fault addr f:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Present bit in contextfault reason 02] Present bit in context entry is clear
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] xt entry is clear
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault addr:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Present bit in context e:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Present bit in context entry is clear
Sep 15 06:55:48 kvolny kernel: DRHD::00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Present bitresent bit in context entry is clear
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0<3>DRHD: handling fault status reg 2
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault addr fffff000<3>DMAR:[DMA Read] Request device [0d:00.0] fault addr fffff000[fault reason 02] Present bit in context entry is clear
Sep 15 06:55:48 kvolny kernel: DRHD: handling fau[fault reason 02] Presed:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Present bit in contex
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Pr
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault addr fffff000 
Sep 15 06:55:48 kvolny kernel: DMAR:[fault reason 02] Present bit in
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device 
Sep 15 06:55:48 kvolny kernel: DRHD: handling fault status reg 2
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00.0] fault ad
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] R
Sep 15 06:55:48 kvolny kernel: DRHD: handling fault status reg 2
Sep 15 06:55:48 kvolny kernel: DMAR:[DMA Read] Request device [0d:00:[fault reason 02] Present bit in context entry is clear


Expected results:
(no errors)

Additional info:
the device is
0d:00.0 SD Host controller: Ricoh Co Ltd Device e822 (rev 01)

I really do not know what is behind those messages, I don't use this component, don't know if it works or not

Comment 1 Chuck Ebbert 2010-09-15 13:01:03 UTC

*** This bug has been marked as a duplicate of bug 605888 ***


Note You need to log in before you can comment on or make changes to this bug.