Bug 63414 - --version shows many things but not the version
Summary: --version shows many things but not the version
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-13 14:07 UTC by Krzysio (Chris) Leszczynski
Modified: 2015-01-07 23:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 17:26:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Krzysio (Chris) Leszczynski 2002-04-13 14:07:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
up2date --version
shows, many things, in a green ``about update agent'' box, but the current
version isn't actually present there.
Also up2date-nox --version shows the ``empty'' version

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Just run 
  $ up2date --version
or
  $ up2date-nox --version
	

Actual Results:  I saw the green box with title about. But the version wasn't there.

Expected Results:  The GNU standards indicate that the program should put the
version string to stdout and then exit with exit code 0.  Well, actually about
box with a version string would be OK too.

Additional info:

Comment 1 Adrian Likins 2002-04-15 17:26:25 UTC
hmm, build problem of some sort...

Looks like something in our new build setting is causing
the version field to not get subsituted in.

gafton, any clues?

Comment 2 Adrian Likins 2002-04-24 22:20:11 UTC
should be fixed in 2.7.77 or higher


Note You need to log in before you can comment on or make changes to this bug.