Bug 634205 - Bluetooth always disabled on startup.
Bluetooth always disabled on startup.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, Reopened
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-09-15 10:01 EDT by Steven Haigh
Modified: 2010-10-01 08:23 EDT (History)
7 users (show)

See Also:
Fixed In Version: bluez-4.71-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-01 08:23:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Haigh 2010-09-15 10:01:47 EDT
Description of problem:
Bluetooth is always disabled on startup after systemd -> upstart change.

Version-Release number of selected component (if applicable):
4.71-1
4.71-2
4.71-3

How reproducible:
Every boot.

Steps to Reproduce:
1. Boot system & log into gnome.
2. Check bluetooth icon.
3. Disable Bluetooth and Enable it again to get BT working. (only works on 4.71-1)
  
Actual results:
Bluetooth is disabled on boot.

Expected results:
Bluetooth should be enabled on boot.

Additional info:
4.71-1 will enable after a disable / enable.
4.71-2 & 4.71-3 does not enable properly at all.
Comment 1 Adam Williamson 2010-09-15 10:08:35 EDT
proposing for f14beta blocker discussion, as it's a regression associated with the upstart reversion (it works with systemd) and could potentially affect network connectivity for some.
Comment 2 Bill Nottingham 2010-09-15 11:40:39 EDT
I've actually had this not work *with* systemd. (where it starts up disabled, and needs a disable/enable cycle to enable itself.)
Comment 3 Adam Williamson 2010-09-15 11:44:41 EDT
It worked with systemd as of 4.71-2 (prior to that, it didn't work as you describe). I confirm the regression from 4.71-2+systemd (where it works fine) to 4.71-2+upstart or 4.71-3+upstart (doesn't work, even with a cycle).
Comment 4 John Poelstra 2010-09-15 14:04:56 EDT
Bastien let me know privately that he is will not be able to work on this bug today.
Comment 5 Bill Nottingham 2010-09-15 14:53:29 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=2469704 may or may not work.
Comment 6 Adam Williamson 2010-09-15 18:31:14 EDT
That one doesn't work on boot, but does come up after a disable/enable cycle (which would be good enough for this to definitely not be a beta blocker, imo).
Comment 7 Adam Williamson 2010-09-16 05:49:17 EDT
can you submit -4 as an update? it seems to be better than -3, at least. i expect we'd probably reject this as a blocker but take it as a nth, if I gaze into my crystal ball; i really just added it to the blocker list to make sure we tracked it. in fact, i'm gonna move it to nth, the  blocker justification is tenuous.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Fedora Update System 2010-09-17 10:54:25 EDT
bluez-4.71-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bluez-4.71-4.fc14
Comment 9 Steven Haigh 2010-09-18 00:10:53 EDT
This doesn't seem to have been pushed yet... Are we waiting on anything at all?
Comment 10 Steven Haigh 2010-09-18 00:23:24 EDT
Also: I installed 4.71-4 via the download link on admin.fedoraproject.org - however this does not fix this bug. Bluetooth still remains disabled on boot. It is however a slight improvement on -2 as you can disable / enable BT to make it work again.
Comment 11 Adam Williamson 2010-09-18 02:22:01 EDT
Yeah, I had the same experience.

The package is waiting because we're in Beta freeze and I guess it didn't get pulled for RC1 (my fault, I didn't quite get to talk to releng about the NTH blocker thing yet).
Comment 12 Fedora Update System 2010-09-20 14:43:00 EDT
bluez-4.71-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bluez'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bluez-4.71-4.fc14
Comment 13 Fedora Update System 2010-09-22 00:10:30 EDT
bluez-4.71-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Steven Haigh 2010-09-22 00:15:44 EDT
This bug still remains with 4.71-4.
Comment 15 Adam Williamson 2010-09-22 04:08:51 EDT
Indeed: -4 makes it work after a disable/enable in the applet, but it's still disabled on startup, which needs fixing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Adam Williamson 2010-09-22 04:09:10 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Fedora Update System 2010-09-22 07:49:41 EDT
bluez-4.71-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/bluez-4.71-5.fc14
Comment 18 Fedora Update System 2010-09-22 14:42:49 EDT
bluez-4.71-5.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bluez'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/bluez-4.71-5.fc14
Comment 19 Steven Haigh 2010-09-25 11:11:03 EDT
I can confirm this is fixed in -5. ok to close IMHO.
Comment 20 Adam Williamson 2010-09-27 21:39:15 EDT
this is a final blocker, as it's a part of the default panel configuration which doesn't work right.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 21 Adam Williamson 2010-09-27 21:41:10 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 22 Fedora Update System 2010-10-01 08:23:23 EDT
bluez-4.71-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.