Bug 63423 - adobe courier euro symbol
adobe courier euro symbol
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 12:22 EDT by Michael Redinger
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-20 14:50:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
XFree config file (3.67 KB, text/plain)
2002-04-20 09:14 EDT, Michael Redinger
no flags Details
xfs config file (1.47 KB, text/plain)
2002-04-20 09:14 EDT, Michael Redinger
no flags Details
XFree log file (25.61 KB, text/plain)
2002-04-20 09:15 EDT, Michael Redinger
no flags Details

  None (edit)
Description Michael Redinger 2002-04-13 12:22:16 EDT
The euro symbol in -Adobe-Courier-Medium-R-Normal
(XFree86-ISO8859-15-75dpi-fonts) very ugly. It's only only readable for font
size >= 14. size 12 doesn't really look like the euro symbol anymore, 10 is
completely unreadable.
Unfortunately quite some applications use this font as default, most often using
size 12 ...
Comment 1 Mike A. Harris 2002-04-15 17:14:40 EDT
What is the exact XLFD you are using to trigger this?

Before I can debug it I need to reproduce it exactly as you see it.
Comment 2 Mike A. Harris 2002-04-19 19:27:54 EDT
I need to know the following information before I can even begin to look into
this problem.

1) I need you to attach the output of "locale" command so I can see your i18n
   settings

2) I need to know the exact XFree86 version and release you are using.

3) I need to know the exact keyboard layout you are using, and how you type
   the euro key on it.  (I've tried for 30 minutes and have yet to even see
   the euro symbol).

4) Are you using GNOME or KDE, or something else.  If KDE do you have font
   antialiasing enabled.

5) I need you to attach your X server log, X config file, and xfs config
   file, so I can analyze the font paths, and other items.

Comment 3 Mike A. Harris 2002-04-19 20:20:05 EDT
I just got gfontsel to display a euro in various fonts with different sizes,
and the euro symbol in the mentioned font looks fine at 14, and at 12 it
has shrunk to a size which IMHO doesndt have enough pixels to make it look
nice.

IMHO, if what I am seeing and you are seeing is the same thing, then I
dont consider this a bug.  Ugly fonts due to bad rendering, bad aliases,
or some other programatical error are something that might be able to
be fixed, however, if the font files themselves contain bad or ugly glyphs,
then I consider that a problem with the font files themselves, and something
the font author needs to address.  We dont edit or design fonts here.

Nonetheless, please provide the above information so I can make sure
my hypothesis is correct, and that we are both seeing the same thing.

Thanks.
Comment 4 Michael Redinger 2002-04-20 09:13:40 EDT
I think we're seeing the same thing (although I'd consider it a bug, but I
understand your point why Red Hat does not resolv this problem).

My settings:

locale:
LANG=de_AT@euro
LC_CTYPE="de_AT@euro"
LC_NUMERIC="de_AT@euro"
LC_TIME="de_AT@euro"
LC_COLLATE="de_AT@euro"
LC_MONETARY="de_AT@euro"
LC_MESSAGES="de_AT@euro"
LC_PAPER="de_AT@euro"
LC_NAME="de_AT@euro"
LC_ADDRESS="de_AT@euro"
LC_TELEPHONE="de_AT@euro"
LC_MEASUREMENT="de_AT@euro"
LC_IDENTIFICATION="de_AT@euro"
LC_ALL=


X version: XFree86-4.2.0-6.62


keyboard:
        Option  "XkbRules"      "xfree86"
        Option  "XkbModel"      "pc102"
        Option  "XkbLayout"     "de"
        Option  "XkbVariant"    "nodeadkeys"

I enter the euro key is "AltGr - E"

I'm using KDE (with and without antialiasing)

Comment 5 Michael Redinger 2002-04-20 09:14:27 EDT
Created attachment 54704 [details]
XFree config file
Comment 6 Michael Redinger 2002-04-20 09:14:57 EDT
Created attachment 54705 [details]
xfs config file
Comment 7 Michael Redinger 2002-04-20 09:15:44 EDT
Created attachment 54706 [details]
XFree log file
Comment 8 Mike A. Harris 2002-04-20 14:59:58 EDT
Thanks.  I looked at your config, and used it to reproduce here.  I'm seeing
the same thing I saw yesterday basically - the font just doesn't look good
at lower sizes.  I'm not sure it could really be made to look better though
either.  My suggestion is to just use a different font that looks better
at the particular size.

One thing I did notice though in your xfs configuration, is that you have
got the 75dpi and 100dpi font paths listed both with and without the
":unscaled".  I suggest removing the 75/100dpi entries that do not have
the :unscaled, and leaving only the :unscaled entries configured.  Also
do this for the "misc" directory as well.  The result will be much better
looking fonts.  Bitmap fonts that get scaled, are very ugly.  Hope
this helps.

Sorry about not being able to do anything about the ugly euro glyph.  Perhaps
the font designer can rework it for the future.

Just a side note..  The "MODIFIED" bug state, is a state for developers
to put a bug in after a fix has been made that needs testing, but which
the developer wants confirmation the fix works before closing with the
final resolution.  "Fix waiting for confirmation (change status to MODIFIED)"
I thought I would mention that, as a few people have put their bug reports
into "MODIFIED" state, and if a developer doesn't notice that mistake in
the bugzilla email that gets sent out, then the bug most likely will never
be seen again unless the given developer queries for bugs in MODIFIED
state often - which generally doesn't occur.

Don't want to see people accidentally closing their own bug reports.  ;o)

Take care!
Comment 9 Michael Redinger 2002-04-20 17:54:00 EDT
Concerning the xfs configuration: the file was generated during install (GUI, custom, everything), I didn't modify anything. Bug?

Ok, if that font is simply plain ugly, should the applications use another default font?
(I added some bugs for some apps first but closed them again and decided to file a bug report against the font package).

Thanks for the note about bug states.


Note You need to log in before you can comment on or make changes to this bug.