Bug 63439 - Bad: up2date corrupted rpm database
Bad: up2date corrupted rpm database
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 20:11 EDT by J.M.Roth
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-14 14:58:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
zipped tar archive of corrupt /var/lib/rpm directory (5.48 MB, application/octet-stream)
2002-04-13 20:20 EDT, J.M.Roth
no flags Details

  None (edit)
Description J.M.Roth 2002-04-13 20:11:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I had about 15 updates in up2date. I updated them. Right after some gnome 
component was installed the db problems started. Right now I'm at a loss. The 
rpm dbs seem trashed.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 J.M.Roth 2002-04-13 20:20:13 EDT
Created attachment 53764 [details]
zipped tar archive of corrupt /var/lib/rpm directory
Comment 2 Jeff Johnson 2002-04-14 12:05:28 EDT
Unfortunately, an rpmdb is too large for
bugzilla attachments.

Describe "trashed" in detail please, so that
I can tell you what to do.
Comment 3 J.M.Roth 2002-04-14 14:03:06 EDT
Well, the upload worked well. Must've been about 5 megs.
Anyway, this is what I get:

1) When I do an rpm -qa:
kudzu-0.99.23-1
error: rpmdb: damaged header instance #116 retrieved, skipping.
apmd-3.0final-34
lokkit-0.50-6
vixie-cron-3.0.1-63
ghostscript-fonts-5.50-3
mpage-2.5.1-7
perl-HTML-Tagset-3.03-3
perl-Parse-Yapp-1.04-3
perl-XML-Encoding-1.01-2
perl-libxml-enno-1.02-5
error: rpmdb: damaged header instance #403 retrieved, skipping.
error: rpmdb: damaged header instance #415 retrieved, skipping.
...
...

Finally, it segfaults.

2) rpm --rebuilddb -v gives me this:
error: rpmdb: damaged header instance #116 retrieved, skipping.
error: rpmdb: damaged header instance #403 retrieved, skipping.
error: rpmdb: damaged header instance #415 retrieved, skipping.
*** dbiUpdateRecord: uh is NULL
Segmentation fault

Cool, eh?

3) Trying a db_dump Packages-ORIG | db_load Packages just hangs (at least it 
was running at 100% for the last 15 hours without a result)

Thanks for helping
Comment 4 Jeff Johnson 2002-04-14 14:33:57 EDT
OK. If you give me a pointer (i.e. URL, attachments won't work)
then I'll try to save what I can.

Meanwhile, what's different about your machine from other?
Is it an SMP machine? What CPU? What kernel? What else
was happening while you were running up2date?

I'm trying for info that might allow reprodcing the problem.
Comment 5 J.M.Roth 2002-04-14 14:58:14 EDT
I don't really know what might've been different, except for that on this 
system I didn't run it for a while.
Right now it's giving me creeps when thinking about running up2date on more 
important production systems with RH 7.2, since I read about similar problems 
already elsewhere
Actually up2date and everything else ran just fine until the error occured.

Here is the file: http://roth.lu/rpm.tar.gz

+++ CPUINFO
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 8
model name      : Pentium III (Coppermine)
stepping        : 6
cpu MHz         : 804.034
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat 
pse36 mmx fxsr sse
bogomips        : 1605.63

+++ KERNEL
Linux version 2.4.9-31 (bhcompile@daffy.perf.redhat.com) (gcc version 2.96 
20000731 (Red Hat Linux 7.1 2.96-98)) #1 Tue Feb 26 07:11:02 EST 2002

You can have a login for that machine if you like. Mail me privately in that 
case.

Thanks
Comment 6 Jeff Johnson 2002-04-14 15:26:39 EDT
Thanks for the info.

Hmmm, db3_dump and db3_load had problems
with rpm/Packages. So did my my delete program.

db4 worked fine, removing instance #582 (ghostscript?)
eliminated the segfault. A rpm --rebuilddb fixed the rest.

There's a repaired copy of your rpm/Packages at
	ftp://people.redhat.com/jbj/rpmdb-63439-FIX.tar.gz
Download and install by doing
	cd /var/lib
	mv rpm/Packages rpm/Packages-ORIG
	tar xzvf rpmdb-63439-FIX.tar.gz
	rpm --rebuilddb -vv

Nope, dunno what happened.

Note You need to log in before you can comment on or make changes to this bug.