Bug 63442 - Many apps missing window titles
Many apps missing window titles
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-13 20:44 EDT by Brian Ryner
Modified: 2007-04-18 12:41 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-14 23:16:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 2002-04-13 20:44:48 EDT
Description of Problem:

After a default installation, most applications do not show the window title in
the title bar.  Applications that are missing titles include Mozilla and
Nautilus file windows.  For whatever reason, gnome-terminal has a window title.

Version-Release number of selected component (if applicable):

sawfish-1.0.1-7

How Reproducible:

always

Steps to Reproduce:
1. Performed default installation of the beta, selecting Workstation install
with GNOME and KDE, selecting GNOME as the default.
2. Booted the system
3. Logged in as the user account I created during installation

Actual Results:

Most windows are missing their window titles.

Expected Results:

The window titles should be present.

Additional Information:
Comment 1 Havoc Pennington 2002-04-13 20:51:31 EDT
What is your locale? ("echo $LANG", "cat /etc/sysconfig/i18n")

Does downgrading Sawfish to 7.2 version fix this?
Comment 2 Brian Ryner 2002-04-14 03:08:19 EDT
> What is your locale? ("echo $LANG", "cat /etc/sysconfig/i18n")

en_US.iso885915

> Does downgrading Sawfish to 7.2 version fix this?

It doesn't seem to.
Comment 3 Havoc Pennington 2002-04-14 09:36:58 EDT
I think the problem is the locale then - can you try changing that locale 
to "en_US.ISO8859-1" (note hyphen and caps), or just choosing a different language
from the gdm menu before you log in.

If that's the issue then this is an anaconda bug, since it wrote the bad locale.
If it's the locale you should also have a bunch of errors in ~/.xsession-errors
about "locale not supported by Xlib" or the like.
Comment 4 Havoc Pennington 2002-04-14 22:52:27 EDT
Hmm, I'm told we fixed the locale issue by changing X to recognize 
iso885915 as a valid locale - so maybe an X upgrade is required. Don't 
know if the fixed X is in rawhide yet.
Comment 5 Brian Ryner 2002-04-14 23:16:53 EDT
On the gdm login screen, I selected Language->American English, which presented
me with the rather confusingly-worded dialog:

"You have selected American English as your language, but American English is
your default language.  Would you like to make American English the default?"

At any rate, this made it so that LANG is set to en_US.ISO-8859-1, and the
window titles appear properly.

I don't recall selecting anything out of the ordinary as far as language during
the installation.  I did select 104-key keyboard, would that have something to
do with it?
Comment 6 Havoc Pennington 2002-04-14 23:26:49 EDT
No the problem isn't your fault, it's just that the installer wrote out a locale
that X did not understand. So Sawfish couldn't load fonts correctly.

Problem has been fixed by making X understand said locale, in latest X version.

Note You need to log in before you can comment on or make changes to this bug.