Bug 63443 - Permission-changing dialog appears repeatedly
Permission-changing dialog appears repeatedly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks: 61901
  Show dependency treegraph
 
Reported: 2002-04-13 20:55 EDT by Brian Ryner
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-15 17:33:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Ryner 2002-04-13 20:55:19 EDT
Description of Problem:

After configuring my DSL connection using internet-druid, I started neat to
activate the connection (which should really be an option at the end of the
configuration wizard, but that's another bug).  I checked the option to activate
the connection on boot, activated the connection, and on exit received multiple
dialogs of the form:

"May I change /etc/sysconfig/networking/devices/ifcfg-eth[0|1] from mode 600 to
644?"

Worse, even after saying yes to these dialogs, going back into neat to confirm
my settings caused the dialogs to appear again when I exited.

Version-Release number of selected component (if applicable):

redhat-config-network-0.9.21-1

How Reproducible:

always

Steps to Reproduce:
1. Configure an internet connection using internet-druid
2. Go into neat to activate the connection
3. Exit neat

Actual Results:

Dialogs appear as previously described.

Expected Results:

No dialogs should appear, because the permissions that these files are created
with (during installation) should match the ones that neat is checking for.
Comment 1 Harald Hoyer 2002-04-15 06:11:43 EDT
yes-case fixed in current release...  
permissions in anaconda should/can be 0644 again, no more passwords inside
Comment 2 Jeremy Katz 2002-04-15 11:53:56 EDT
Changed

Note You need to log in before you can comment on or make changes to this bug.