Bug 634556 - language support is not installed by selecting few languages.
language support is not installed by selecting few languages.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
14
All Linux
medium Severity medium
: ---
: ---
Assigned To: Naveen Kumar
Fedora Extras Quality Assurance
AcceptedNTH
: i18n
Depends On:
Blocks: F14-accepted/F14FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2010-09-16 07:09 EDT by A S Alam
Modified: 2013-07-02 21:05 EDT (History)
6 users (show)

See Also:
Fixed In Version: system-config-language-1.3.5-4.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-18 01:39:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
s-c-l-634556.patch (3.02 KB, patch)
2010-10-11 06:50 EDT, Naveen Kumar
no flags Details | Diff

  None (edit)
Description A S Alam 2010-09-16 07:09:02 EDT
Description of problem:
While selecting Hindi, Punjabi,Japanese, zh_CN, ko_KR, Language support is not installed. But if you install lao, Malay (Malaysia) language, then it install language support

Version-Release number of selected component (if applicable):
system-config-langauge1.3.5-1.fc14

How reproducible:
Everytime

Steps to Reproduce:
1. run system-config-langauge
2. select language Korean (Republic...)
3. press OK
4. as root, try to run 'yum groupinstall korean-support'
5. check if any package is there to install

Actual results:
there are all language support package yet need to install with yum.

Expected results:
there should be no package to install with step 5, (as s-c-language should install language support package)


Additional info:
1) /etc/sysconfig/i18n - it is ko_KR
2) it is problem with few languages only, like *_IN, CJK
Comment 1 Naveen Kumar 2010-09-21 04:57:31 EDT
It works for all "mandatory" packages listed in comps for all languages, hence I guess this is not a bug. For example I do not see any "mandatory" packages in zh_CN, ko_KR and japanese but it works and installs if you remove lohit-punjabi-fonts, lohit-hindi-fonts for punjabi & hindi respectively, because these are listed as "mandatory".
Comment 2 A S Alam 2010-09-21 06:24:10 EDT
Try to use s-c-lang, and then  run 'yum groupinstall <LAMG>-support, it will show differences. it should not be "mandatory" only, but works same way as 'yum' doing.
Comment 3 Naveen Kumar 2010-09-21 18:38:34 EDT
(In reply to comment #2)
> Try to use s-c-lang, and then  run 'yum groupinstall <LAMG>-support, it will
> show differences. it should not be "mandatory" only, but works same way as
> 'yum' doing.

I guess then, this makes it a feature request...
Comment 4 Adam Williamson 2010-09-27 21:43:58 EDT
Beta's now out, so moving from Beta nice-to-have list to Final nice-to-have list.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2010-10-01 17:29:03 EDT
This was discussed at the 2010-10-01 blocker / NTH review meeting, and accepted as a nice-to-have.
Comment 6 Naveen Kumar 2010-10-11 06:50:06 EDT
Created attachment 452689 [details]
s-c-l-634556.patch

patch for s-c-l to install language support even for conditional and default packages.
Comment 7 Fedora Update System 2010-10-11 07:15:58 EDT
system-config-language-1.3.5-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/system-config-language-1.3.5-4.fc14
Comment 8 Fedora Update System 2010-10-11 22:38:23 EDT
system-config-language-1.3.5-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-language'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/system-config-language-1.3.5-4.fc14
Comment 9 A S Alam 2010-10-12 01:42:58 EDT
it is working as problem mentioned.
tried with Chinese, Bengali (India), Gujarati, Hindi, Telugu.
system-config-language installed required packages and 'yum groupinstall <LANG>-support has nothing do later. s-c-l and yum groupinstall <LANG>-support now works same way.

Tested Package: system-config-language-1.3.5-4.fc14.noarch
Comment 10 Fedora Update System 2010-10-18 01:38:55 EDT
system-config-language-1.3.5-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.