Bug 634596 - need --enable-shared-js
Summary: need --enable-shared-js
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 635336 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-09-16 13:34 UTC by Colin Walters
Modified: 2010-09-23 02:54 UTC (History)
7 users (show)

Fixed In Version: xulrunner-2.0-0.1b6.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-22 11:24:15 UTC


Attachments (Terms of Use)
enable shared js (980 bytes, patch)
2010-09-16 13:34 UTC, Colin Walters
no flags Details | Diff

Description Colin Walters 2010-09-16 13:34:34 UTC
Created attachment 447746 [details]
enable shared js

Necessary for gjs and libproxy-mozjs.  See attached patch.

Comment 1 Yanko Kaneti 2010-09-19 07:42:05 UTC
*** Bug 635336 has been marked as a duplicate of this bug. ***

Comment 2 Martin Stransky 2010-09-22 11:24:15 UTC
fixed in xulrunner-2.0-0.1b6.fc15

Comment 3 Braden McDaniel 2010-09-23 02:54:07 UTC
It's worth noting here that this version of libmozjs breaks with the previous API--a lot.

And there's no soname change. So in spite of the fact that Fedora's infrastructure may think that a package built against XULRunner 1.9.2's libmozjs will work with this one, the odds of that being true are very low.

If there's no mass-rebuild planned for F15, this ought to be well-publicized.


Note You need to log in before you can comment on or make changes to this bug.