Bug 63464 - Konqueror page draw bug using Keramik style
Summary: Konqueror page draw bug using Keramik style
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: skipjack-beta2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL: http://bugzilla.redhat.com/bugzilla/q...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-04-14 09:32 UTC by Peter van Egdom
Modified: 2007-04-18 16:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-17 15:02:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter van Egdom 2002-04-14 09:32:07 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-9; Linux) 
 
Description of problem: 
When using KDE 3.0 with the Keramik style, some internet pages do not show 
some buttons, switching the style to another (e.g. KDE default) fixes this 
problem. 
 
This problem can be seen at http://bugzilla.redhat.com/bugzilla/query.cgi 
 
Scroll down to the bottom of the page to 'Query actions'.  
If you're using Keramik style there are no buttons 
- Bug Number Ascending 
- Submit query 
- Reset back to the default query 
 
Setting the style to for example KDE default or .NET style  
fixes this problem (after closing and starting Konqueror) 
 
This problem can be reproduced by setting Keramik again and closing 
and starting Konqueror again and going to Red Hat's Bugzilla 
page. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Set KDE 3.0 style to Keramik 
2. Load http://bugzilla.redhat.com/bugzilla/query.cgi 
3. Scroll to bottom and observe the missing buttons (see Description). 
  
 
Actual Results:  The buttons : 
- Bug Number Ascending 
- Submit query 
- Reset back to the default query 
do not appear. 
 
Expected Results:  The buttons  
- Bug Number Ascending 
- Submit query 
- Reset back to the default query 
should have appeared. 
 
Additional info: 
 
Videocard : Matrox Millennium 4Mb. 
Width: 1152 
Height: 864 
Depth: 16 
 
 
Version     : 3.0.0                             Vendor: Red Hat, Inc. 
Release     : 9                             Build Date: za 13 apr 2002 
01:57:01 CEST 
Install date: zo 14 apr 2002 09:55:53 CEST      Build Host: 
stripples.devel.redhat.com 
Group       : User Interface/Desktops       Source RPM: 
kdebase-3.0.0-9.src.rpm

Comment 1 Rex Dieter 2002-04-17 15:02:31 UTC
I can confirm that I've also been bitten by this bug.  It has problems drawing 
buttons/checkboxes on about ANY form.

Comment 2 Bernhard Rosenkraenzer 2002-04-17 15:36:09 UTC
I couldn't reproduce this at any time, but the style has been removed from the 
current packages because some people had problems with it.

Comment 3 Rex Dieter 2002-04-17 16:04:45 UTC
Another datapoint... I was using RedHat 7.2 (+XFree86 4.1.0-15) when I 
experienced this problem.  Maybe XFree 4.2 helps here...

Comment 4 Bernhard Rosenkraenzer 2002-04-17 16:18:18 UTC
 That's likely to be the problem, X 4.1.0 is totally broken for alpha 
blending.

Comment 5 Rex Dieter 2002-04-17 16:26:53 UTC
Are you still dead-set on removing Keramik then? Or would a Requires: XFree86 
>= 4.2.0 suffice? 
 
-- Rex

Comment 6 Rex Dieter 2002-04-17 16:43:45 UTC
Well, for the record, I just upgraded to XFree-4.2.0-6.666 and the problem did
NOT go away.

Comment 7 Bernhard Rosenkraenzer 2002-04-17 17:32:45 UTC
Probably an X driver problem then - no problems whatsoever here with a Matrox  
G400 and an ATI Radeon RV100, but bug reports on bugs.kde.org keep coming in 
from anyone with X <= 4.1.0

Comment 8 Rex Dieter 2002-04-17 18:15:50 UTC
 FYI, I'm was using a Matrox G200 (+XFree-4.2.0-6.666).  Wierd.


Note You need to log in before you can comment on or make changes to this bug.