Bug 63477 - up2date-gnome download stage ends at 99%
up2date-gnome download stage ends at 99%
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
skipjack-beta2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 71225 (view as bug list)
Depends On:
Blocks: 61901 67218
  Show dependency treegraph
 
Reported: 2002-04-14 10:00 EDT by Michael Schwendt
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 16:14:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2002-04-14 10:00:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
At the end of downloading all new packages in up2date-gnome, the progress bar
stopped at 99%. Since up2date allowed me to proceed with the "Next" button, this
must be an inaccurate calculation somewhere in up2date.


Version-Release number of selected component (if applicable):
up2date-gnome-2.7.77-7.x.3


How reproducible:
Didn't try


Expected Results:  The progress bar should show 100%.
Comment 1 Adrian Likins 2002-04-24 18:17:55 EDT
hmm, odd.  I cant seem to duplicate this. I'll keep an
eye out for it...
Comment 2 Michael Schwendt 2002-04-25 04:59:25 EDT
I was testing whether already downloaded packages would be accepted and hence
had at least one fully downloaded package in up2date's spool directory. Maybe
that is an important detail for reproducing this.
Comment 3 Adrian Likins 2002-08-21 13:57:48 EDT
think I stumbled across this one...

looks like in some cases the progress bar update for the gui
progress bars could land outside the 0.0...1.0 range and throw
a warning and not update the progress bar. 

Made a couple fixes to make sure this doesnt happen and havent
seen since.
Comment 4 Adrian Likins 2002-08-21 14:09:18 EDT
*** Bug 71225 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.