Bug 63489 - Direct 3D rendering no longer working with Rage Mobility M3, r128 driver.
Direct 3D rendering no longer working with Rage Mobility M3, r128 driver.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-14 15:09 EDT by Alex Cruise
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-26 12:21:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/XFree86.0.log (29.08 KB, text/plain)
2002-04-14 18:43 EDT, Alex Cruise
no flags Details
/etc/X11/XF86Config-4 (1.80 KB, text/plain)
2002-04-14 18:44 EDT, Alex Cruise
no flags Details

  None (edit)
Description Alex Cruise 2002-04-14 15:09:03 EDT
Description of Problem: 
 
In RH 7.2, direct rendering worked beautifully with my laptop's 8MB Rage 
Mobility M3 chip.  In 7.2.92, it doesn't.  "glxinfo" reports "Direct 
rendering: no" even though I have r128 and agpgart loaded, and the appropriate 
modules appear to be loaded from /etc/X11/XF86Config-4. 
 
I will attempt to attach my XF86Config-4 and XFree86.0.log. 
 
Version-Release number of selected component (if applicable): 
 
4.2.0-6.47 
 
How Reproducible: 
 
It's been like this on my laptop since I installed Skipjack b1. 
 
Steps to Reproduce: 
1. Install/upgrade to skipjack b1 on a laptop equipped with an 8MB Rage 
Mobility M3  
2. Run Xconfigurator and choose appropriate values 
3. Run /usr/X11R6/lib/xscreensaver/gears -fps -delay 0 
 
Actual Results: 
 
Observed framerate of ~ 42fps 
 
Expected Results: 
 
At least 100fps 
 
Additional Information:
Comment 1 Alex Cruise 2002-04-14 18:43:21 EDT
Created attachment 53792 [details]
/var/log/XFree86.0.log
Comment 2 Alex Cruise 2002-04-14 18:44:08 EDT
Created attachment 53793 [details]
/etc/X11/XF86Config-4
Comment 3 Warren Togami 2002-04-14 21:32:21 EDT
What distro & version was your DRI working previously?
Comment 4 Mike A. Harris 2002-04-15 05:06:32 EDT
The config file attached and the logfile attached do not seem to line up.
Your X server log does not anywhere try to load the DRI module, however
the config file explicitly lists it.

Also, the log file shows:

(WW) R128(0): Static buffer allocation failed -- need at least 9216 kB video memory
(II) R128(0): Direct rendering disabled

Lower your resolution and/or color depth.  Try using 16 bit color.

Does this change things?



Comment 5 Alex Cruise 2002-04-15 13:54:29 EDT
I'm fairly certain accelerated 3D was working fine at 1024x768x24bpp in RH7.2, 
but in any case it works now with 16bpp.  

A programmer comment on another Bugzilla entry by a Voodoo3 owner mentioned 
that the driver had been changed to turn off DRI if insufficient memory was 
available on the card... This laptop has a working AGP implementation, and in 
the past I've been able to play any number of hardware-accelerated 3D games 
without difficulty, so perhaps the driver is being too conservative about the 
amount of memory it needs?

Thanks anyway :)
Comment 6 Mike A. Harris 2002-04-15 14:28:22 EDT
That is specific solely to the Voodoo 3 and Banshee, and is a specific
limitation of the hardware/driver combination.  AGP hardware with
AGP textures are not limited by the physical video card memory.

Can you attach your /var/log/messages file, from system bootup, until
you've started XFree86 completely?  That could help determine if
there are GART issues.  If the GART wont load, then DRI wont work either.
Comment 7 Alex Cruise 2002-04-15 15:04:03 EDT
The agpgart and r128 modules are loading without issue... Like I said 
accelerated 3D is *working* now with 16-bit colour, I just wish I could use it 
with 24-bit. :)

Apr 15 09:39:58 onus kernel: Linux agpgart interface v0.99 (c) Jeff Hartmann
Apr 15 09:39:58 onus kernel: agpgart: Maximum main memory to use for agp 
memory: 203M
Apr 15 09:39:58 onus kernel: agpgart: Detected Intel 440BX chipset
Apr 15 09:39:58 onus kernel: agpgart: AGP aperture is 64M @ 0xf4000000
Apr 15 09:39:58 onus kernel: [drm] AGP 0.99 on Intel 440BX @ 0xf4000000 64MB
Apr 15 09:39:58 onus kernel: [drm] Initialized r128 2.2.0 20010917 on minor 0
Comment 8 Mike A. Harris 2002-05-30 01:38:42 EDT
It has been a while since the topic came up, but I believe the r128 does not
support 3D accel in 24bpp.  I'll have to confirm that by examining the driver
source and chip specs.
Comment 9 Mike A. Harris 2002-07-26 12:21:46 EDT
Make sure you are using the RHL 7.3 i586, i686 or athlon kernel.
The i386 kernel does not have DRM in it.

Please confirm you are using our 2.4.18-5 one of our i586/i686/athlon kernels
(current updated erratum).
Comment 10 Mike A. Harris 2002-09-08 06:34:24 EDT
Assuming problem no longer occurs in XFree86 4.2.0-72, and closing
as fixed in RAWHIDE.  If the problem still exists, please reopen,
and supply above requested test results, info, etc.

Note You need to log in before you can comment on or make changes to this bug.