Bug 634980 - various issues with parted's new blkpg kernel partition change notification mechanism,
various issues with parted's new blkpg kernel partition change notification m...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-17 09:41 EDT by Hans de Goede
Modified: 2010-09-22 00:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: parted-2.3-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 00:09:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2010-09-17 09:41:09 EDT
Hi,

First of all, see:
https://bugzilla.redhat.com/show_bug.cgi?id=629719#c30

Also I'm wondering if the new code will work properly with > 15 partitions, this should be tested. Thinking about this the use of blkext majors rather then the main disk major for partitions (which the kernel does for partitions > 15 on scsi disks and for any and all md partitions), might be the cause of the mdraid partition issues.

Regards,

Hans
Comment 1 Fedora Update System 2010-09-17 15:09:16 EDT
parted-2.3-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/parted-2.3-2.fc14
Comment 2 Adam Williamson 2010-09-18 03:54:57 EDT
I tested this with the 18-partitions-on-a-USB case, and it works great: no error messages, partitions show up immediately in /proc/partitions and ls /dev/sd* . Thanks Hans. If someone could test the mdraid case that initially exposed the bug, that would be great.
Comment 3 Brian Lane 2010-09-18 14:33:00 EDT
dlehman tested it on the mnraid system and said it worked fine.
Comment 4 Fedora Update System 2010-09-20 14:41:21 EDT
parted-2.3-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update parted'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/parted-2.3-2.fc14
Comment 5 Fedora Update System 2010-09-22 00:09:00 EDT
parted-2.3-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.