Bug 635 - Odd errors from Perl
Odd errors from Perl
Status: CLOSED DUPLICATE of bug 90
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-28 12:12 EST by Daniel Senie
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-31 10:17:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 1998-12-28 12:12:50 EST
I'm getting odd errors on 5.2 from a script that's supposed
to be an example of using the chat2.pl package. The URL
listed above is where the script is available. I get
different results on my RHL 4.2 box, though it still does
not run.

I can't be sure at this stage whether this is a RedHat bug,
a Perl bug, a bug in the module, or what. I'm trying to get
a WORKING example of chat2.pl from somewhere (anywhere!) so
I can indeed be sure.

fennel.senie.com% chat2.examp bolton
Prototype mismatch: sub chat::__need_size_t vs () at (eval
43) line 1.
String found where operator expected at (eval 147) line 1,
near "&__const 'struct sockaddr'"
        (Missing operator before  'struct sockaddr'?)
open: Bad file descriptor at chat2.examp line 38.
Comment 1 Daniel Senie 1998-12-28 12:15:59 EST
Apparently the URL field in the bug tracking form doesn't get recorded
properly. I'll email the script in question to dkl@redhat.com shortly.
Comment 2 Daniel Senie 1998-12-28 12:35:59 EST
Further update. I now have a VERY simple script that works fine on my
4.2 RHL, and blows up on 5.2. The script is included below. Also
included are the PERL versions from the two boxes (which are slightly
different apparently).

Script:
#!/usr/bin/perl

require "chat2.pl";

$where = 'gate.senie.com';
$whereport = 23;
$handle = &chat'open_port($where, $whereport);
print "result of open_port is $handle\n";

On the 4.2 system:

perl -v gives:

This is perl, version 5.004_04 built for i386-linux

On the 5.2 system the script fails with:

Prototype mismatch: sub chat::__need_size_t vs () at (eval 43) line 1.
String found where operator expected at (eval 147) line 1, near
"&__const 'struct sockaddr'"
        (Missing operator before  'struct sockaddr'?)
result of open_port is chatsymbol000001

and the perl -v there shows:

This is perl, version 5.004_04 built for i386-linux
(with 1 registered patch, see perl -V for more detail)
Comment 3 Jeff Johnson 1998-12-31 10:17:59 EST
*** This bug has been marked as a duplicate of 90 ***

Note You need to log in before you can comment on or make changes to this bug.