Bug 635094 - selinux is blocking the clamd service
Summary: selinux is blocking the clamd service
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F14Target
TreeView+ depends on / blocked
 
Reported: 2010-09-17 18:51 UTC by Nicolas Mailhot
Modified: 2010-09-23 07:33 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2010-09-23 07:33:01 UTC


Attachments (Terms of Use)

Description Nicolas Mailhot 2010-09-17 18:51:11 UTC
On boot:

clamd.amavisd.service     loaded failed       failed                             LSB: The clamd server running for amavisd

# systemctl restart clamd.amavisd.service
Job failed, see system logs for details.
# setenforce permissive
# systemctl restart clamd.amavisd.service
#

There are no sealert to explain why clamd is being blocked. When clamd is down no mail is processed (the system runs postfix, amavis and dovecot) so this is the sole ready I have to disable selinux protection here. It worked fine in rawhide for months and was broken just in time for F14 alpha

clamav-0.96.2-1400.fc14.x86_64
clamav-data-0.96.2-1400.fc14.noarch
clamav-filesystem-0.96.2-1400.fc14.noarch
clamav-lib-0.96.2-1400.fc14.x86_64
clamav-scanner-0.96.2-1400.fc14.noarch
clamav-scanner-upstart-0.96.2-1400.fc14.noarch
clamav-server-0.96.2-1400.fc14.x86_64
clamav-update-0.96.2-1400.fc14.x86_64
selinux-policy-3.9.5-2.fc14.noarch
selinux-policy-targeted-3.9.5-2.fc14.noarch

Comment 1 Daniel Walsh 2010-09-22 21:18:58 UTC
Try
# semodule -DB
# systemctl restart clamd.amavisd.service

Turn back on the dontaudit rules by executing
#semodule -B

Comment 2 Nicolas Mailhot 2010-09-23 07:32:46 UTC
I seems to have been fixed by today's updates

clamav-0.96.3-1400.fc14.x86_64
clamav-scanner-upstart-0.96.3-1400.fc14.noarch
clamav-filesystem-0.96.3-1400.fc14.noarch
clamav-scanner-0.96.3-1400.fc14.noarch
clamav-data-0.96.3-1400.fc14.noarch
selinux-policy-3.9.5-3.fc14.noarch
clamav-update-0.96.3-1400.fc14.x86_64
clamav-lib-0.96.3-1400.fc14.x86_64
clamav-server-0.96.3-1400.fc14.x86_64
selinux-policy-targeted-3.9.5-3.fc14.noarch


Note You need to log in before you can comment on or make changes to this bug.