This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 63519 - rhr-net-1.7-7 always fails (RHL 7.2)
rhr-net-1.7-7 always fails (RHL 7.2)
Status: CLOSED RAWHIDE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: net (Show other bugs)
1.7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Kloiber
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-15 10:55 EDT by Glen A. Foster
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-26 11:51:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated RPMS (17.74 KB, application/octet-stream)
2002-04-23 14:20 EDT, Rob Landry
no flags Details

  None (edit)
Description Glen A. Foster 2002-04-15 10:55:34 EDT
Description of Problem: Regardless of what hardware (all HP, of course :-) I run
the network certification test on, the test reports FAILED.

Version-Release number of selected component (if applicable):
# rpm -qa | grep rhr
rhr-interact-1.7-7
rhr-core-1.7-7
rhr-auto-1.7-7

How Reproducible: 100% (always)

Steps to Reproduce:
1. install rhr packages
2. edit /etc/rhr.conf (don't touch the eth0 config, though)
3. run redhatready and select only the network test

Actual Results: FAILED results every time.  Experimenting with the code in
/etc/init.d/rhr_functions shows that the lines NOT being filtered out are:

Finished 256 requests
Finished 256 requests
Finished 256 requests
Finished 256 requests
Finished 256 requests

Expected Results: I would expect to be filtered out... e.g., they appear normal
since there's no configuration changes or anything special added about the
network tests.  I propose as a solution, to add to /etc/init.d/rhr_functions:

grep -iv "Finished [0-9]* requests" |

... to the output-filtering algorithm on lines 91-105.


Additional Information: Not to be aggressive or anything about this issue, but
does every 7.2 system fail certification like this, or am I doing something
wrong (or missing something like a test-script upgrade)?
Comment 1 Glen A. Foster 2002-04-15 11:39:56 EDT
Hi Chris, I don't know if this is really yours or not to own; but your name is
100% better than Jeff Abbott's (the original assignee).
Comment 2 Rob Landry 2002-04-23 14:20:25 EDT
Created attachment 55004 [details]
Updated RPMS
Comment 3 Rob Landry 2002-04-23 14:23:02 EDT
I've updated the rhr_functions scripts to also exclude the "Finished blah
requests" lines.  ab has changed and now prints just those three lines to stderr
for some reason leaving the remaining output on stdout.  The X detection has
been updated as well as the tape test (cat could take all of the ram away from
the system (or at least to the point that cat couldn't claim anymore) so this
has been fixed.
Comment 4 Glen A. Foster 2002-04-26 11:50:54 EDT
Fix verified on my system.  Thanks, Rob!
Comment 5 Glen A. Foster 2002-08-15 12:09:14 EDT
Closing bug (since Rob didn't do it :-)

Note You need to log in before you can comment on or make changes to this bug.