This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 635296 - virt-resize fails resizing ntfs on qcow2
virt-resize fails resizing ntfs on qcow2
Status: CLOSED DUPLICATE of bug 635298
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-18 15:52 EDT by sean
Modified: 2010-09-21 17:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-21 17:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sean 2010-09-18 15:52:39 EDT
Description of problem:
 have a 15G qcow2 xp vm with only 1 partition:
-rw-------. 1 root root 10514137088 Sep 12 11:10 XP.img

I want to resize it to 20G. So I :

virsh vol-create-as --format raw  windows XP-new-20G.img 20G
Vol XP-new-20G.img created

-rw-------. 1 root root 21474836480 Sep 12 13:17 XP-new-20G.img

But:

virt-resize --expand /dev/sda1 XP.img XP-new-20G.img
Summary of changes:
/dev/sda1: partition will be resized from 14.6G to 20.0G
/dev/sda1: content will be expanded using the 'ntfsresize' method
part_add: do_part_add: parted: /dev/vdb: Error: The location 41938815s
is outside of the device /dev/vdb. at /usr/bin/virt-resize line 1092.

Version-Release number of selected component (if applicable):
libguestfs-tools-1.5.9-1.fc14.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard W.M. Jones 2010-09-21 17:22:18 EDT

*** This bug has been marked as a duplicate of bug 635298 ***

Note You need to log in before you can comment on or make changes to this bug.