Bug 635330 - Boot menu is missing in F14 Beta RC2 install discs
Boot menu is missing in F14 Beta RC2 install discs
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity urgent
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-09-18 23:04 EDT by Andre Robatino
Modified: 2013-01-10 01:13 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-14.17.4-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 00:07:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Boot menu for each of the F14 Beta RC2 install discs (63.11 KB, image/png)
2010-09-18 23:04 EDT, Andre Robatino
no flags Details
Look for syslinux-vesa-splash.jpg in the correct location (924 bytes, patch)
2010-09-19 11:35 EDT, Tom "spot" Callaway
no flags Details | Diff
Install image files in the right location (1.32 KB, patch)
2010-09-19 19:17 EDT, Jesse Keating
no flags Details | Diff

  None (edit)
Description Andre Robatino 2010-09-18 23:04:04 EDT
Created attachment 448253 [details]
Boot menu for each of the F14 Beta RC2 install discs

Description of problem:
In 14 Beta RC2, the boot menu is gone in all install discs (netinst, DVD and CD for both i386 and x86_64). Screenshot attached below.

Version-Release number of selected component (if applicable):
F14 Beta RC2
Comment 1 Andre Robatino 2010-09-18 23:42:22 EDT
Seen on bare metal as well (i386 DVD). Also seen by another user on bare metal on i386 netinst:

http://lists.fedoraproject.org/pipermail/test/2010-September/093850.html
Comment 2 Steve Tyler 2010-09-19 07:39:48 EDT
Confirmed with qemu-kvm and with bare metal (CDRW):
$ sha256sum Fedora-14-Beta-x86_64-netinst.iso
9a3f3dffb09d9972c3db203d80f2cd415c53a8653a5121ea54f4ec4210926cea  Fedora-14-Beta-x86_64-netinst.iso
Comment 3 Adam Williamson 2010-09-19 10:30:31 EDT
confirmed here too on KVM. This is obviously a Beta blocker. Could this be something to do with the new artwork? Did we ever actually test a non-live image with the changed artwork package?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Steve Tyler 2010-09-19 11:15:56 EDT
What is splash.lss?

[stephent@walnut isolinux]$ pwd
/mnt/iso/isolinux
[stephent@walnut isolinux]$ ls -lF splash*
-rw-r--r--. 1 root 101737 69611 Sep 18 12:30 splash.lss
[stephent@walnut isolinux]$ grep splash isolinux.cfg 
menu background splash.jpg
Comment 6 Dennis Gilmore 2010-09-19 11:18:24 EDT
to give some extra info i filed bug #635289 as i had to install extra packages into the chroot to compose rc2  seems to be due to something different in fedora-logos
Comment 7 Dennis Gilmore 2010-09-19 11:19:41 EDT
adam the delta is actually smaller 
https://admin.fedoraproject.org/updates/fedora-logos-14.0.0-1.fc14
https://admin.fedoraproject.org/updates/sugar-chat-67-1.fc14
 
the rest were already in rc1
Comment 8 Steve Tyler 2010-09-19 11:22:32 EDT
[stephent@walnut F14]$ isoinfo -lJ -i F14-Beta-RC1/Fedora-14-Beta-x86_64-netinst.iso | grep splash
----------   0    0    0          615828 Sep 17 2010 [  15936 00]  splash.jpg 
----------   0    0    0           63584 May  3 2010 [ 113443 00]  splash.xpm.gz 

[stephent@walnut F14]$ isoinfo -lJ -i F14-Beta-RC2/Fedora-14-Beta-x86_64-netinst.iso | grep splash
----------   0    0    0           69611 Sep 18 2010 [  15936 00]  splash.lss 
----------   0    0    0          462737 Sep 18 2010 [  15970 00]  syslinux-vesa-splash.jpg 
----------   0    0    0           68392 Sep 13 2010 [ 128968 00]  splash.xpm.gz
Comment 9 Tom "spot" Callaway 2010-09-19 11:35:35 EDT
Created attachment 448294 [details]
Look for syslinux-vesa-splash.jpg in the correct location

There is a reason I asked the anaconda folks in advance about where the logos should end up. This patch adjusts the mk-images.x86 code to look in the correct location for syslinux-vesa-splash.jpg.

Current code doesn't find this file, so the syslinux.cfg does not get written out correctly (and syslinux.cfg gets copied to isolinux.cfg).

With this fix, the menu will start working again.
Comment 10 Jesse Keating 2010-09-19 19:16:37 EDT
I sent a patch to you (spot) 4~ months ago for fedora-logos that updates the Makefile to put the images where anaconda expects them.

I think the proper fix here is to update fedora-logos to install things in the right place instead of modifying anaconda (again).

I'll attach the patch here too.
Comment 11 Jesse Keating 2010-09-19 19:17:53 EDT
Created attachment 448321 [details]
Install image files in the right location

Install images in the right location.
Comment 12 Tom "spot" Callaway 2010-09-19 19:45:51 EDT
*sigh* Okay, I'm only going to say this once, because you're wrong, Jesse.

I applied Jesse's patch back when he originally sent it to me. His patch claims that /usr/share/anaconda/ is the appropriate place for all of the anaconda related pixmaps in fedora-logos. 

Then, last week, I decided it would be good to doublecheck the path locations while I was adding the new Fedora 14 art to fedora-logos, just to make sure that /usr/share/anaconda/ was the correct place. It didn't look correct to me, so I went to #anaconda and asked dlehman and bcl to confirm the pathing.

Sep 13 15:00:54 <bcl>   It used to be in /usr/lib/anaconda-runtime/boot/ and should now be in /usr/share/anaconda/boot according to my reading of things :)
Sep 13 15:21:01 <dlehman>	looks like /usr/share/anaconda/boot

They both confirmed that /usr/share/anaconda was NOT correct. I had them double-check it, and asked them to update this wiki page with the correct set of paths:

https://fedoraproject.org/wiki/F14_Artwork/Fedora-Logos-Packaging

If you check the history, you'll see that Dlehman made the changes there on September 13, 2010. And in fact, the rest of the anaconda code does assume /usr/share/anaconda/boot for the splash files and /usr/share/anaconda/pixmaps for everything else. 

So please, don't throw old patches at me. I went above and beyond this time to get it right (since I have screwed it up before), and /usr/share/anaconda/boot is where the anaconda team wanted these images to live. livecd-utils has already been patched to reflect that pathing, and its a two line fix in anaconda.
Comment 13 Jesse Keating 2010-09-20 02:46:23 EDT
Deeply sorry, this is my mistake.  It just looked like the patch you provided to anaconda reverted to different paths than what I sent you earlier.  I'll blame a long day of riding in a van across the European country side and lack of judgement looking at bugzilla before I had a fresh night's sleep.

Again I apologize.
Comment 14 Fedora Update System 2010-09-20 19:31:55 EDT
anaconda-14.17.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.17.4-1.fc14
Comment 15 Fedora Update System 2010-09-20 23:50:55 EDT
anaconda-14.17.4-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-14.17.4-1.fc14
Comment 16 Fedora Update System 2010-09-22 00:07:20 EDT
anaconda-14.17.4-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2010-10-06 18:02:41 EDT
anaconda-14.18-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/anaconda-14.18-1.fc14

Note You need to log in before you can comment on or make changes to this bug.