Bug 635390 - [abrt] flumotion-0.6.1-2.fc14: ihooks.py:490:load_tail:ImportError: No module named 'flumotion.admin.gtk.main.main'
Summary: [abrt] flumotion-0.6.1-2.fc14: ihooks.py:490:load_tail:ImportError: No module...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: flumotion
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Vander Stichele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:17815c09
: 670098 (view as bug list)
Depends On:
Blocks: Python27
TreeView+ depends on / blocked
 
Reported: 2010-09-19 11:30 UTC by Adam Williamson
Modified: 2011-05-09 01:52 UTC (History)
17 users (show)

Fixed In Version: flumotion-0.8.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-05 05:04:06 UTC


Attachments (Terms of Use)
File: backtrace (1.11 KB, text/plain)
2010-09-19 11:30 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2010-09-19 11:30:40 UTC
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/bin/python /usr/bin/flumotion-admin
comment: Crashed on startup.
component: flumotion
executable: /usr/bin/flumotion-admin
kernel: 2.6.36-0.20.1.rc3.git4.fc14.x86_64
package: flumotion-0.6.1-2.fc14
reason: ihooks.py:490:load_tail:ImportError: No module named 'flumotion.admin.gtk.main.main'
release: Fedora release 14 (Laughlin)
time: 1284895781
uid: 501

backtrace
-----
ihooks.py:490:load_tail:ImportError: No module named 'flumotion.admin.gtk.main.main'

Traceback (most recent call last):
  File "/usr/bin/flumotion-admin", line 44, in <module>
    boot.boot(PROGRAM_PATH, gtk=True, gst=False)
  File "/usr/lib64/flumotion/python/flumotion/common/boot.py", line 269, in boot
    main = reflect.namedAny(path)
  File "/usr/lib64/flumotion/python/flumotion/twisted/reflect.py", line 54, in namedAny
    topLevelPackage = __import__(trialname)
  File "/usr/lib64/flumotion/python/flumotion/common/package.py", line 58, in import_module
    locals, fromlist)
  File "/usr/lib64/python2.7/ihooks.py", line 408, in import_module
    m = self.load_tail(q, tail)
  File "/usr/lib64/python2.7/ihooks.py", line 490, in load_tail
    raise ImportError, "No module named '%s'" % mname
ImportError: No module named 'flumotion.admin.gtk.main.main'

Local variables in innermost frame:
head: 'main'
i: 4
mname: 'flumotion.admin.gtk.main.main'
self: <flumotion.common.package._PatchedModuleImporter instance at 0x15a18c0>
m: None
q: <module 'flumotion' from '/usr/lib64/flumotion/python/flumotion/__init__.pyc'>
tail: ''

How to reproduce
-----
1. Installed flumotion
2. Ran flumotion-admin-server
3.

Comment 1 Adam Williamson 2010-09-19 11:30:42 UTC
Created attachment 448285 [details]
File: backtrace

Comment 2 rajat 2010-11-09 12:49:25 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.when open it got crash
2.
3.

Comment 3 DeepPurpleFedora 2010-11-23 03:05:31 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
was removing and moving audio and video

Comment 4 Helber Maciel Guerra 2010-11-25 23:48:44 UTC
The solution for this bug is in:
https://code.fluendo.com/flumotion/trac/ticket/1469

The patch is:
https://code.fluendo.com/flumotion/trac/attachment/ticket/1469/ticket_1469.diff

Replacing:
r = str(sys.exc_info()[1])
To:
r = str(sys.exc_info()[1]).strip("'")

Comment 5 pauloguapo 2010-11-26 09:44:46 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.I can reproduce video
2.
3.


Comment
-----
now  any comment

Comment 6 martya 2010-12-01 23:06:45 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Applications
2.sound and video 
3. Flumotion Video graphical tool


Comment
-----
opened up the  menu option for the graphical interface

Comment 7 DeepPurpleFedora 2010-12-07 20:25:25 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.start it
2.
3.

Comment 8 Dave Malcolm 2010-12-16 23:13:57 UTC
Looks like Peter built 0.8.0 for F14:
  http://koji.fedoraproject.org/koji/buildinfo?buildID=197193
but never put an update out through Bodhi:
  https://admin.fedoraproject.org/updates/flumotion

Would it be worth creating an update for this?  (Is flumotion in F14 dead-on-arrival as-is?)

Comment 9 Roman 2010-12-17 21:32:47 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. run flumotion
2.
3.

Comment 10 Franco Ciocca 2010-12-22 18:59:26 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.mentre lo aprivo
2.
3.

Comment 11 Timothy Davis 2011-01-12 03:52:45 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started flumotion admin server
2.
3.


Comment
-----
sudo yum install flumation
applications -> sound & video -> flumotion server admin

Comment 12 Timothy Davis 2011-01-12 13:58:41 UTC
Installing from yum works but the package won't run (see above notes)
I installed from source with subversion and it ran fine (configuration is another issue :D)

My guess is something is wrong in the yum package.

Comment 13 Ajay Desai 2011-01-17 07:57:54 UTC
*** Bug 670098 has been marked as a duplicate of this bug. ***

Comment 14 Akuma55 2011-01-25 23:45:35 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. crash on run
2.
3.

Comment 15 Pedro Jaramillo 2011-03-28 15:20:45 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I just installed it
2. It did not run at all
3. I am using fedora 14


Comment
-----
It did installa but it did not run at all.

Comment 16 Pedro Jaramillo 2011-03-30 04:37:34 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.INtalled it
2. tried to run it
3. crashed


Comment
-----
No explanation , I have not been able to run it

Comment 17 Pedro Jaramillo 2011-04-01 14:51:21 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.INtalled it
2. tried to run it
3. crashed


Comment
-----
No explanation , I have not been able to run it

Comment 18 Pedro Jaramillo 2011-04-05 21:53:29 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Installed
2. Run
3. Crashed


Comment
-----
Installed, runned, and it crashes the very first time!

Comment 19 eduardovra 2011-04-06 20:32:48 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. just opened
2.
3.

Comment 20 geminic86 2011-04-09 12:24:40 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Push button and crash
2.
3.

Comment 21 Václav Mocek 2011-04-15 11:15:40 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Install flumotion
2. Run "flumotion-admin" as a user.
3.


Comment
-----
I just tried to set it up.

Comment 22 Dave 2011-04-23 18:18:13 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Clicked start and it crashed.
2.
3.

Comment 23 Helber Maciel Guerra 2011-04-25 16:22:22 UTC
Package: flumotion-0.6.1-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Just install and start.
2. The fix is on my comments.
3.


Comment
-----
The problem is compatibility with python 2.7 (twisted module).
To fix this, change file:
/usr/lib64/flumotion/python/flumotion/twisted/reflect.py
Line 60 change:
            r = str(sys.exc_info()[1])
to:
            r = str(sys.exc_info()[1]).strip("'")

Comment 24 Fedora Update System 2011-04-29 18:59:57 UTC
flumotion-0.8.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/flumotion-0.8.1-1.fc15

Comment 25 Fedora Update System 2011-04-30 00:46:46 UTC
Package flumotion-0.8.1-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing flumotion-0.8.1-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/flumotion-0.8.1-1.fc15
then log in and leave karma (feedback).

Comment 26 Fedora Update System 2011-04-30 07:16:33 UTC
flumotion-0.8.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/flumotion-0.8.1-1.fc14

Comment 27 Helber Maciel Guerra 2011-05-01 18:41:04 UTC
It works for me.

Comment 28 Fedora Update System 2011-05-05 05:04:00 UTC
flumotion-0.8.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2011-05-09 01:52:01 UTC
flumotion-0.8.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.